Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just installed Server 2008 r2, standard core edition on a server, and enabled hyperv. I cannot get the Hyperv console to connect to the machine, I get the message saying

Connecting to the virtual machine management interface

followed by

You might not have permission to perform this task

I have used HVRemote tool to ensure all user and firewall permissions are ok, all the services have started correctly, I've even turned of the firewall to see if that helps, all to no avail. Any ideas?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Well I found the solution to the problem, it turns out accessing the hyper-v server using the IP address causes this, if you use the host name it works ok.

share|improve this answer

Open port 137 and 138 on the firewall on Hyper-V server ;-)

Manage FireWall on Hyper-V Server Core : netsh advfirewall set currentprofile settings remotemanagement enable

For change IP configuration :

Change IP Addresse : Netsh interface ipv4 set address name=LAN source=static address=192.168.1.254 mask=255.255.255.0 gateway=192.168.1.1

Change IP DNS : Netsh interface ipv4 add dnsserver name="LAN" address=192.168.1.100 index=1

Show interfaces : Netsh interface ipv4 show interfaces

Show interfaces config : Netsh interface ipv4 show config

Rename Interface : netsh interface set interface name="Connexion au réseau local" newname=LAN

Disable network Interface : netsh interface set interface LAN disable

change Computer name : Netdom renamecomputer OldName /NewName:NewName

Olivier D.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.