Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I setup an aws EC2 instance and installed wordpress as mentioned in the docs.(http://docs.aws.amazon.com/AWSEC2/latest/UserGuide/hosting-wordpress.html)

I assigned a static external IP Elastic IP: 54.200.141.14 to the aws instance.

I registered a domain name http://www.techweblogs.co.uk/ and mapped domain techweblogs.co.uk to Elastic IP: 54.200.141.14

Everything went fine till now. When I access http://www.techweblogs.co.uk/ the Site is taking a long time to load...

Once the site is loaded all styling is now gone and the links points to ec2-xx-xx-143-xxx.us-west-2.compute.amazonaws.com

I don't know where am I going wrong. Pl. help!

share|improve this question

You need to set the correct URL in WordPress's General settings pane in both locations.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.