Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to dist-upgrade my ubuntu server on my percona cluster but it failed with this message

The following packages have unmet dependencies:
libmysqlclient18 : Depends: libmariadbclient18 (= 5.5.33a+maria-1~precise) but it is not installable

And here is the package listing

# dpkg --list | grep -E 'percona|mysql'
ii  libdbd-mysql-perl                   4.020-1build2                     Perl5 database interface to the MySQL database
iU  libmysqlclient18                    5.5.33a+maria-1~precise           Virtual package to satisfy external depends
ii  mariadb-common                      5.5.33a+maria-1~precise           MariaDB database common files (e.g. /etc/mysql/conf.d/mariadb.cnf)
ii  percona-xtrabackup                  2.1.5-680-1.precise               Open source backup tool for InnoDB and XtraDB
ii  percona-xtradb-cluster-client-5.5   5.5.31-23.7.5-438.precise         Percona Server database client binaries
ii  percona-xtradb-cluster-common-5.5   5.5.33-23.7.6-496.precise         Percona Server database common files (e.g. /etc/mysql/my.cnf)
ii  percona-xtradb-cluster-galera-2.x   157.precise                       Galera components of Percona XtraDB Cluster
ii  percona-xtradb-cluster-server-5.5   5.5.31-23.7.5-438.precise         Percona Server database server binaries
ii  php5-mysql                          5.3.10-1ubuntu3.8                 MySQL module for php5

During the install of the server, mariadb and galera cluster have first been installed. Then removed to be replaced by percona XtraDBCluster. So i think this is the source of the problem. But how can i resolve this without reinstalling all ?

UPDATE 1

# apt-cache policy libmariadbclient18
libmariadbclient18:
  Installed: (none)
  Candidate: (none)
  Version table:
     5.5.32+maria-1~precise 0
        100 /var/lib/dpkg/status
share|improve this question
    
Please provide the output of apt-cache policy libmariadbclient18 –  fuero Oct 21 '13 at 8:44
    
Updated with apt-cache policy libmariadbclient18 output –  Spin0us Oct 21 '13 at 8:48

2 Answers 2

Please verify that your software repository lists are in correct working order. It seems to me that APT has no access to the package you mentioned.

According to this, it's in the Maria DB PPA which APT must know about.

So put this in /etc/apt/sources.list.d/mariadb.list:

http://ftp.osuosl.org/pub/mariadb/repo/5.5/ubuntu precise main

and run

apt-get update
apt-get -d install libmysqlclient18
dpkg -i /var/cache/apt/archives/libmysqlclient18*.deb
dpkg --configure --pending
apt-get install -f
share|improve this answer
    
I still got error. dpkg: dependency problems prevent configuration of libmysqlclient18: libmysqlclient18 depends on libmariadbclient18 (= 5.5.33a+maria-1~precise); however: Package libmariadbclient18 is not installed. dpkg: error processing libmysqlclient18 (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. –  Spin0us Oct 21 '13 at 9:27
    
I've updated my answer, this should fix the problem you're having with the unpacked, but yet unconfigured package. –  fuero Oct 21 '13 at 9:54
    
dpkg failed dpkg: dependency problems prevent removal of libmysqlclient18: php5-mysql depends on libmysqlclient18 (>= 5.5.13-1). libdbd-mysql-perl depends on libmysqlclient18 (>= 5.5.13-1). percona-xtradb-cluster-client-5.5 depends on libmysqlclient18 (>= 5.5.31-23.7.5-438.precise). –  Spin0us Oct 21 '13 at 10:13
    
Did you do dpkg --configure --pending before running apt-get install -f? –  fuero Oct 21 '13 at 10:15
    
Yes and i got the same error. –  Spin0us Oct 21 '13 at 12:41
up vote 0 down vote accepted

I finaly found the solution.

# wget http://www.percona.com/redir/downloads/Percona-XtraDB-Cluster/LATEST/deb/precise/x86_64/libmysqlclient18_5.5.33-23.7.6-496.precise_amd64.deb
# dpkg -i libmysqlclient18_5.5.33-23.7.6-496.precise_amd64.deb
# apt-get install -f
# apt-get upgrade

And all is fine now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.