Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using Ubuntu Server 13.04 on my mail system. I am just setting the Postfix and Amavis. In every config for communication I am using 127.0.0.1 as IP address to pass mails to amavis. When I look to the logs its still trying to connect to Amavis with my eth0 IP address which is connected to the internet. I dont want to allow this IP address in the configs. Is there any way how to tell Ubuntu to use the 127.0.0.1 instead of my internet IP address? I dont know why this is happening. Thank you.

Edit: More info

This is what I set in postfix main.cf:

content_filter = amavis:[127.0.0.1]:10024 

and master.cf:

127.0.0.1:10025  inet  n  -       -       -       -       smtpd
  -o mynetworks=127.0.0.0/8

Also this is what I have in /etc/amavis/conf.d/50-user:

@inet_acl = qw( 127.0.0.1 );

But when I try to receive a mail, in the logs there is:

 amavis[29607]: () (!)DENIED ACCESS from IP 1.2.3.4, policy bank ''

where 1.2.3.4 is my IP address of eth0 interface.. Why its not accessing it with 127.0.0.1 but with eth0 IP address? I think I am missing something and this might be just how it works.. I am just asking if there is any explanation or possibility to change this. Because now I always have to add my IP address to inet_acl and the subnet mynetworks.. Thanks.

share|improve this question
3  
Show us exactly what is happening and exactly what you have configured. –  Michael Hampton Oct 21 '13 at 17:24
    
I have just added more info.. Hope it will make more sense what I mean.. Thank you for the reply @MichaelHampton –  InToSSH Oct 22 '13 at 11:28

1 Answer 1

Check for inet_interfaces option in Postfix. I suppose Postfix should explicitly bind 127.0.0.1 to use in output communications.

FYI: http://www.cyberciti.biz/faq/postfix-receive-mail-on-specific-network-interfaces/

share|improve this answer
    
Thank you for suggestion. Anyway since I have to use both 127.0.0.1 and my inet address its not gonna make any change.. I have tried it and its doing still the same. –  InToSSH Oct 22 '13 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.