Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a simple network that consists of a Windows 2003 Server connected to a number of Windows XP Home machines. I do not have a domain setup, so the computers are connected to the same workgroup.

I share a number of resources on the Windows 2003 Server (files and printers). I add an account for each user on the 2003 machine. The accounts have the same username and password that the users use to log in to the Windows XP machines.

This approach seems to work quite well. The users can log in to Windows XP Home and they then have access to the 2003 shares and printers without having to provide their credentials again. I believe this is called pass-through authentication.

However, I have one account on one of the Windows XP Home machines that the pass-through authentication method does not work, and I cannot determine why.

When I create a new account on the XP Home machine and a corresponding account on the Windows 2003 machine, the pass through works. So I know it's not something global to the machine.

I have tried making the XP Home account an 'Administrator' account but that does not work.

I have checked that the XP Home username/password matches the one on the 2003 machine.

So what else am I missing?

share|improve this question
    
You're probably going to hear it a thousand times before long, but this is exactly why XP Professional exists... –  Mark Henderson Aug 16 '09 at 21:18
    
@Farseeker, no doubt, but that's not an answer since I have 4 Windows XP Home machines\accounts where pass-through authentication works. –  jmatthias Aug 16 '09 at 23:35

1 Answer 1

up vote 1 down vote accepted

On XP home machines, sometimes although you login as "Reginald Smith Esq." - because that's what you typed in when windows prompted for "Please type in your name" - the profile name is "owner" or ever worse "Valued Customer". Open a command prompt and see what name it really uses. If they are not the same, try creating the goofy named account on the server and see if that gets you anywhere.

One more thing to try. When you create a user on the XP Home machine that doesn't exist on the server, do you end up with a login screen when you attempt to access a share ?

I'm putting my 10 foot pole away for another few minutes :)

share|improve this answer
    
You are correct, the username was Owner. I added an account named Owner on the 2003 machine and all is well. You are the MAN! –  jmatthias Aug 19 '09 at 3:27
    
I'm sure in someone's mind this behavior makes sense :) –  dimitri.p Aug 19 '09 at 3:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.