Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

It takes almost 5 minutes for eth link to get into state UP after reboot in debian 7 x64. The problem is those drivers are not in standard kernel, I had to install them from source (igb-5.0.6.tar.gz at https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=13663 )

The drivers work but it takes so long for eth to recognize it's on - ip link set dev eth0 up does not help. The LED on eth switch is off too until kernel turns eth controller on.

Evidence:

pydmesg (https://gist.github.com/saghul/542780#file-pydmesg) output:

[2013-10-22 18:16:00] ip6_tables: (C) 2000-2006 Netfilter Core Team
[2013-10-22 18:20:49] igb: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
[2013-10-22 18:20:49] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[2013-10-22 18:20:49] br0: port 1(eth0) entering forwarding state
[2013-10-22 18:20:49] br0: port 1(eth0) entering forwarding state
[2013-10-22 18:20:49] ADDRCONF(NETDEV_CHANGE): br0: link becomes ready
[2013-10-22 18:20:58] br0: port 1(eth0) entering forwarding state

PCI devices:

% lspci | grep -i eth
05:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)
06:00.0 Ethernet controller: Intel Corporation I210 Gigabit Network Connection (rev 03)

I have configured them for modprobe this way:

% cat /etc/modprobe.d/igb.conf
alias eth0 igb
alias eth1 igb
options igb IntMode=2,1

Finally, interface config:

% cat /etc/network/interfaces
# The loopback network interface
auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet manual

auto eth1
iface eth1 inet manual
        pre-up ifconfig $IFACE up
        pre-down ifconfig $IFACE down

auto br0
iface br0 inet static
        address 10.0.0.90
        netmask 255.255.255.0
        network 10.0.0.0
        broadcast 192.168.255.255
        gateway 10.0.0.1
        bridge_ports eth0
        bridge_fd 9
        bridge_hello 2
        bridge_maxage 12
        bridge_stp off
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 8.8.8.8
share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.