Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a wireless network where I work.

I've installed TightVNC viewer on a WinXP box, and I'm using it to connect to my laptop which has Ubuntu 9.04 installed.

So far, everything works right up to after I login.

I can see the initial screen of my laptop in the TightVNC viewer, as it is when I first connect.

But if I click on something, enter keystrokes, etc, none of my actions seem to show up.

The actions still happen, as observed on the laptop's screen, but I don't get any output on my WinXP box.

Any ideas why?

share|improve this question
    
Are you using Remote Desktop (vino) on your Ubuntu Box? I'm using that and TightVNC viewer from Vista and having a similar problem. –  Dennis Williamson Sep 17 '09 at 0:11
add comment

4 Answers

up vote 2 down vote accepted

there are a number of options in the TightVNC server, including one ('-viewonly') that disallows keyboard and mouse input from the viewer. On your Ubuntu box, do you have a ~/.vnc/xstartup file defined? Which options are you starting your TightVNC server with?

share|improve this answer
    
He may be using Remote Desktop (vino) which is installed by default, IIRC, on Ubuntu. I'm using the same combination (vino with TightVNC viewer) and am having the same problem. Also, the screen doesn't update (e.g. the clock doesn't change). However, when screen blanking kicks in, it does so on the viewer also and I can move the remote mouse and it wakes up and the clock shows the current time (but again stays unchanged). I have "View only (inputs ignored)" turned off. –  Dennis Williamson Sep 17 '09 at 5:19
add comment

Quoting the message here:

On the remote machine (the one you are remoting to); System->Preferences->Appearance “Visual effects” tab, select None.

Which refers to a Gnome setting on the Ubuntu system. Unfortunately, this turns off Compiz effects like wiggly windows.

share|improve this answer
    
I had tried RealVNC Viewer Free in addition to TightVNC Viewer and got the same results which led me to checking for problems on the host side. –  Dennis Williamson Sep 17 '09 at 7:09
add comment

Here's what I did: killed all vino processes and tightvncserver. Then restarted tightvncserver (without args). Connected to the box (running ubuntu) from an xp box and got what you'd expect--just like you were on the Ubuntu box, only slower.

share|improve this answer
add comment

There are different option for pulling the display ( well basically pull or using events) try changing them. Pulling will be more reliable, but it uses more cpu cycles.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.