Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am attempting to edit a Fedora 19 DVD ISO to add a kickstart file. I then need this ISO burnt to a USB stick for instillation.

The error I get when booting is

Warning: Could not boot.
Warning: /dev/root does not exist

To try and determine which part of the process is failing I have broken the process down in to separate stages.

Step 1:

Burn the original ISO "Fedora-19-x86_64-DVD.iso" (Available -> here) to a pendrive and see if that will install.

dd if=/path/to/iso of=/dev/sdc

Burning this image was successful and it installed without issue.

Step 2:

Exctract the ISO, repackage it and burn it to a pendrive and see if that will install. PLEASE NOTE: The final command in this section has been broken down in to multiple lines for ease of reading, in fact it was run as a single command on one line.

mkdir -p /mnt/linux
mount -o loop /tmp/linux-install.iso /mnt/linux

cd /mnt/
tar -cvf - linux | (cd /var/tmp/ && tar -xf - )

cd /var/tmp/linux

xorriso -as mkisofs -R -J -V "NewFedoraImage" -o ouput/file.iso 
-b isolinux/isolinux.bin -c isolinux/ -no-emul-boot -boot-load-size 4 
-boot-info-table -isohybrid-mbr /usr/share/syslinux/isohdpfx.bin .

This iso was then burnt to a pendrive as before.

dd if=/path/to/iso of=/dev/sdc

This ISO burnt to the pen drive with no problem and will boot. I then see the fedora options screen. After choosing either "Install Fedora 19" or "Test this media & install Fedora 19" I then receive the errors highlighted above.

This means the kickstart file is not to blame, but repackaging the ISO. Is there something I am missing in the repackaging process?

Any input would be great!

NOTE: If it is of any help, I attempted Step 2 with an Ubuntu server ISO and the process was successful.

share|improve this question
up vote 7 down vote accepted

i guess it is because you have chosen a new Volume Id by -V "NewFedoraImage".

I am the developer of xorriso and have experienced a similar problem when experimenting with GPT enhanced isohybrid in Fedora-LiveCD.iso. It did not work unless i used the same -V as with the original image. In an old mail text of mine i see a reference to "/dev/disk/by-label/".

To learn about the original Volume Id, you may do:

  xorriso -indev Fedora-19-x86_64-DVD.iso 2>&1 | grep 'Volume id'

(Leave out "2>&1 | grep 'Volume id'" if you don't get any output)

share|improve this answer
That was exactly it, thank you. Any ideas as to why Fedora is so particular about the volume ID and Ubuntu is not? – dooffas Oct 25 '13 at 9:15
There must be files in the original image which refer to /dev/disk/by-label/...orginal.Volume.Id... . I forgot how exactly i came to the suspicion about Volume Id. Maybe from looking at some fstab. Possibly in the initrd. (I am not much into booting myself. My job is done when BIOS or EFI find their boot images.) – Thomas Schmitt Oct 25 '13 at 11:34
My best suspect in Fedora-LiveCD.iso are /isolinux/isolinux.cfg , /EFI/BOOT/grub.conf , /EFI/BOOT/BOOTX64.conf. They all mention kernel parameters like root=live:CDLABEL=Fedora-LiveCD. "Fedora-LiveCD" is the Volume Id of the original image. – Thomas Schmitt Oct 25 '13 at 11:50

A quick workaround:

In case that link disappears: Upon booting from the USB drive, at 1st screen hit TAB to get the grub command line. Remove the label that says something like 'Fedora-22-xxx' and replace by the label of your USB drive/stick, in several cases I have seen it is "LIVE".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.