Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have php5.4 installed.It runs on freebsd server I also use soap.so extension. But when I start php script (new SoapClient) it stopped.

Apache logs:
tail -f /var/log/httpd-errors.log :
/libexec/ld-elf.so.1: /usr/local/lib/php/20100525/soap.so: Undefined symbol "php_libxml_disable_entity_loader"

I tried reinstall php5-extensions after portupgrade

Can anybody help me? Thanks

share|improve this question

1 Answer 1

I had exactly the same problem and it disappeared after upgrading all packages to latest versions.

I believe it was caused by version mismatch between packages (I installed php-soap later, so it was more recent version).

share|improve this answer
    
"I installed php-soap later". Me too. I had portsnap update and reinstall php-extensions. –  Andrei Zhamoida Nov 1 '13 at 11:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.