Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Summary

I have a very peculiar problem. I am not able to open the "It Works!" page after installing a fresh server with apache. I am able to ssh to the box (from outside the network). Apache seems to be running on my Centos6.4x86_64 box just fine. Nothing useful in /var/logs/httpd/*. What am I missing?

The setup

I am outside the network right now. The "server" is a VM on my home computer running bridged mode.

public ip: A.B.C.D

Host: 192.168.1.5

VM: 192.168.1.8

I have a verizon fios router that is forwarding ports 22, 80, and 8888 to the VM. I am able to ssh over port 22, but I am not able to browse to the public URL over port 80. so A.B.C.D:22 is working, but http://A.B.C.D:80 is not.

What I've tried

nmap to see if it is listening:

nmap -sT -O localhost

Starting Nmap 5.51 ( http://nmap.org ) at 2013-10-25 11:10 EDT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.000040s latency).
Other addresses for localhost (not scanned): 127.0.0.1
Not shown: 996 closed ports
PORT     STATE SERVICE
22/tcp   open  ssh
25/tcp   open  smtp
80/tcp   open  http
3306/tcp open  mysql

I tried going to it locally (lynx) and it does work. So, is the problem in my ports?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Check for iptables config. Only 22 port is usually opened by default on local firewall.

share|improve this answer
    
Awesome! Thanks! For those of you playing at home, that's: iptables -I INPUT -p tcp --dport 80 -j ACCEPT –  Jeff Oct 25 '13 at 15:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.