Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a new server and it's acting strange. Apache seems to work fine for a few minutes, sometimes more than a few minutes, but then it hangs/freezes and php pages are not accessible.

It's as if the website is down completely; things don't load up, but when I do:

service httpd restart

via ssh, everything returns normal. I literally have to do this every few minutes. There is no apache error in /var/logs/httpd.

What could be the problem? I have several other servers but even with the same setup and configuration and version, there is no problem at all on them.

share|improve this question

2 Answers 2

Default logging on httpd on CentOS is /var/log/httpd/*, but your logs may be configured to show up elsewere. Check in your httpd config where your logs go, then check the error_log for clues.

If the server hangs and you see no logs on that file, then you should increase log level/configure logging because an error like the one you describe should definitely show up there.

At the very least, you should get a hit in the access_log which could confirm that you at least are directed to the right server.

share|improve this answer

I rember this issue happened to me before

I rebuild Apache and every things went good again.

please rebuild your apache.

share|improve this answer
    
Hi Ghazzi, do you have any reason to believe that there was something wrong with your initial build of Apache or that the same thing is wrong with the OP's build or that it will be built differently without making any changes to the build process or that Apache is causing the problem with only his PHP pages? If so, could you add that to your answer? –  Ladadadada Oct 30 '13 at 11:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.