Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to use IIS 7 Remote Management installed on Vista Ultimate SP1. Connection is to IIS 7.5 on Windows Server 2008 Webserver R2. Tried on both full & core install. When I connect up, the console wants to download and install new features.

Microsoft.Web.Management.IisClient 7.5.0.0 Microsoft.Web.Management.AspnetClient 7.5.0.0

I check the boxes and click OK and it downloads them and asks if I want to install them, but after I click run it just quits. I tried just choosing one or the other, same thing. I ran IIS Remote tool as administrator. These features installed correctly on my XP machine. Any ideas?

UPDATE : If I had any Rep I would offer like 500 rep to get this fixed!

share|improve this question

2 Answers 2

There was a bug that was fixed in Windows Vista SP2, if you install it your problem will be fixed. Alternatively you can just delete four files that are located at \windows\system32\inetsrv\ directory: Microsoft.Web.Management.AspnetClient.dll Microsoft.Web.Management.Aspnet.dll Microsoft.Web.Management.IisClient.dll Microsoft.Web.Management.Iis.dll

Deleting this files will require you to take ownership of them: (right-click -> properties -> security -> advanced -> owner -> Edit) then set owner to administrators, click ok and close all dialogs. Add permissions for you (right-click -> properties -> security -> edit -> add full permissions for administrators).

Finally delete the files, this change will not cause any side effects and will fix the problem.

share|improve this answer

I am not sure if it will work or install but you can try the Windows 7 Remote Administration Tools. These definitly include the management tools for R2 including IIS 7.5. However I am not sure if it will install on Wibdows Vista. I suspect the official Vista tools will be released when the Server hits public RTM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.