Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I’ve been trying everything; this is the last chance I have.

I moved folders and files from an old Windows Server 2003 File Server to a new FS (Win Server 2008 R2) with DFS and ABE enabled.

Now, a specific Shared Excel file is driving me crazy, out of a sudden, lots of times per day, users are getting the following error while opening that file: Filename.xlsx is locked for editing by ‘another user’. Open ‘Read-Only’ or, click ‘Notify’ to open..

I’ve already followed this, with no joy: http://blogs.technet.com/b/the_microsoft_excel_support_team_blog/archive/2012/05/14/the-definitive-locked-file-post.aspx

In any case, I strongly think this is not client-related, since it never gave that problem in the past with Windows Server 2003. I’ve found and followed many other solutions, nothing.

The users are all utilizing Office 2010 on Windows 7 machines, besides a few users who are still on Windows XP machines.

I appreciate any help, thank you!

share|improve this question
    
We also get this all the time. I've not taken the time to confirm the issue, but I suspect it is related to the time it takes to open the file across the network share. In 100% of our cases when clicking the Notify button the workbook is available for read/write immediately when the file finishes loading. –  squillman Oct 29 '13 at 15:52
    
Hi, thanks! I will give it a try, I've tried on my machine and only waited a few seconds, then closed it. I'm afraid this won't work with me, especially because this problem occurred to me as well and my laptop is connected to the same switch where the Server is, I could understand others (even though switches are connected with fiber cables within each other).. Any other thoughts? –  Simone Oct 30 '13 at 7:07

1 Answer 1

This has to do with the new Trust Settings that are in Office 2010. From the File menu, select Options and then select Trust Center. Then select the File Block Settings. Make sure you have most of the checkboxes cleared. I have only Word 95, 6.0 and Word 2 and earlier set for Open. All the rest of the documents I leave alone. I also have the Open behavior set for Open selected file types in Protected View.

These file types can have macro virus' in them that perhaps the macro checker would not find since they use Word Basic rather than the newer macro controls.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.