Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was in a similar posistion to this question and bound two IP addresses using httpcfg. Since doing this ftp does not seem to be working on IIS6 in Windows Server 2003. Any ideas what could be wrong? The command I ran was:

httpcfg set iplisten -i

I get the following when I try to conenct via Filezilla:

Error:  Connection timed out
Error:  Failed to retrieve directory listing

The log file is returning the following:

#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2009-08-17 13:54:05
#Fields: date time c-ip cs-username cs-method cs-uri-stem sc-status sc-win32-status 
2009-08-17 13:54:05 Client [1]USER Client 331 0
2009-08-17 13:54:05 Client [1]PASS - 230 0

In the ftp site settings I have the site pointing to the IP address used using httpcfg and the port set to 21.

Update: I can see a directory listing if I connect via the inbuilt commandline ftp client in wondows vista. If I try to connect via a windows explorer I start in the incorrect folder and no files are listed just directories.

share|improve this question
More detail perhaps? – Chopper3 Aug 17 '09 at 11:53
still nothing from you about operating system, when you completed the 'ask question' form it said 'provide details', not 'provide the very least possible to form a sentence' - people answer these questions because they can or want to, not out of obligation - put some effort into it yourself! – Chopper3 Aug 17 '09 at 13:57
Added some information. Thanks for the pointers. L – Linda Aug 17 '09 at 14:03 is that clear enough? what about it's NIC setup? what you're trying to achieve etc.? – Chopper3 Aug 17 '09 at 14:08
Unsure on NIC setup have inhertied the machine. All I want is to be able to ftp to the site. Thank you for being patient. – Linda Aug 17 '09 at 14:14

The issue is with IIS. When you use httpcfg you have to restart the IIS admin services, not just IIS (i.e. restarting IIS via 'All Tasks' WON'T WORK). After your 'set iplisten' command, type:

net stop http /y


net start http

Then go into IIS and restart it...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.