Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am doing snmpget from a RHEL machine to the localhost. It works for IPv4 and doesn't work for IPv6.

# snmpget -v2c -c public udp6:[::1] sysName.0
Timeout: No Response from udp6:[::1].

# snmpget -v2c -c public localhost sysName.0
SNMPv2-MIB::sysName.0 = STRING: xxxxvm119

# ping6 2620:0:a07:e402:250:56ff:xx:xx
PING 2620:0:a07:e402:250:56ff:xx:xx(2620:0:a07:e402:250:56ff::xx:xx) 56 data bytes
64 bytes from 2620:0:a07:e402:250:56ff:xx:xx: icmp_seq=1 ttl=64 time=0.025 ms
64 bytes from 2620:0:a07:e402:250:56ff:xx:xx: icmp_seq=2 ttl=64 time=0.039 ms


I have edited /etc/snmp/snmpd.conf to have

agentaddress udp:161
agentaddress udp6:161

com2sec6 readonly default public
rocommunity6 public

and have restarted the snmpd still I see the time out issue. I checked if IPV6 is working by pinging another IPv6 address and ping6 localhost.

what am I missing? Re-posting the same question from stackoverflow to serverfault as server fault seems more appropriate. Leave your answers here.

share|improve this question
    
Have you checked your firewall? –  Michael Hampton Oct 29 '13 at 20:47
    
Yeah I have stopped the firewall and still having the same issue. –  Prem Oct 29 '13 at 20:51
    
Use netstat -a -u6 -n to see if there is something listening on UDP6 port 161. –  JvO Oct 30 '13 at 0:27
    
@JvO, I have made sure snmp is listening on udp6 port 161 by using the following commands. [root@vm119 ~]# lsof -i4UDP:161 snmpd 19136 root 7u IPv4 14558124 0t0 UDP *:snmp [root@vm119 ~]# lsof -i6UDP:161 snmpd 19136 root 8u IPv6 14558125 0t0 UDP *:snmp` –  Prem Nov 1 '13 at 20:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.