Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have to code tiny and simple php script. I don't want to depend on remote servers, so I decided I will install my own environment. My workstation was Windows XP, installed Apache 2.2.11, php 5.2.9 and mysql - 5.1.22. Everything was ok, it worked as it was supposed to work...

Few days ago I upgraded to windows 7. Installed Apache 2.2.13 (keeping the old httpd.conf) and the same versions of php and mysql. Running scripts with the interpreter (using cmd) is ok, but when I try to reach them through the apache it crashes.

Here is my error log:

[Mon Aug 17 15:05:14 2009] [notice] Parent: child process exited with status 255 -- Restarting.

[Mon Aug 17 15:05:14 2009] [notice] Apache/2.2.13 (Win32) PHP/5.2.9 configured -- resuming normal operations

[Mon Aug 17 15:05:14 2009] [notice] Server built: Aug 6 2009 15:50:50

[Mon Aug 17 15:05:14 2009] [notice] Parent: Created child process 6740

[Mon Aug 17 15:05:15 2009] [notice] Child 6740: Child process is running

[Mon Aug 17 15:05:15 2009] [notice] Child 6740: Acquired the start mutex.

[Mon Aug 17 15:05:15 2009] [notice] Child 6740: Starting 64 worker threads.

[Mon Aug 17 15:05:15 2009] [notice] Child 6740: Starting thread to listen on port 80.

Googling about "Parent: child process exited with status 255 -- Restarting." I found that this big is known on windows vista too, but I couldn't find a solution. Thanks!

share|improve this question

1 Answer 1

up vote 1 down vote accepted

my name is Angelo, and I'm a Web Master... I Had this same problem, so i've tried anythings to figure out this problem. Well, here, this problem was with 'libmysql.dll' if you overwrite the 'libmysql.dll' that comes with PHP, for the 'libmysql.dll' comes with MySQL Database Server, that's it. It's simple, recover the 'libmysql.dll' that comes with PHP. I discovered this problem, when i tried to access files with mysql commands. so, that's it. Bye, and apologize for my poor english!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.