Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem with a wordpress site on a server I admin. I don't know anything about wordpress however.

My problem is that we want the site to be accessed over https, bot somehow all requests to https:// URLs are answered by the server with a 302, redirecting to http.

The wordpress site itself is configured to use https, and we see that in the pages that are generated the links are all https links.

In the apache config there are no rewrite rules and no redirects.

However, any request to a https:// URL is answered with a redirect to the equivalent http URL. And I really would like to know where these redirects are coming from, what is generating these redirects.

I've increased the loglevel on the webserver to DEBUG, but did not get any info there. I tried to enable debug logging in wordpress per the recipy I found here: http://codex.wordpress.org/Debugging_in_WordPress But did not get a debug.log file in the directory where one should appear.

I'm really at a loss here, and need to fix this urgently.

Any hints as where to start looking?

Apache is 2.2.14 on Ubuntu. There are several other virtual hosts on this server, using php and https without any problem...

Edit: I created a small info.php script and dropped that in the webservers' root. Calling this yields the output of the script, no redirect is generated. This suggest that it's not the webserver, but wordpress that is doing it.

A second thing I noticed is that the redirect comes with several cookies, one of which has "httponly" set. Could that be it?

I've tried adding this to the wp-config.php:

define('WP_HOME','https://www.domain.com/');
define('WP_SITEURL','https://www.domain.com/');

This did not change a thing...

share|improve this question
    
What are the URLs set to in the WordPress General settings? –  Michael Hampton Nov 1 '13 at 7:53
    
Have you taken a look at this page codex.wordpress.org/Changing_The_Site_URL ? –  HBruijn Nov 1 '13 at 8:28
    
The site url is set to a https url. Links in web pages generated by WP are using this https url. When I click on one of those URLs my browser sends a https request to the host, which then gets redirected to http... It's this redirect from https to http which is the problem. I've tried the suggestions, and hard set the WP_HOME and WP_SITEURL settings, but as expected this did nothing, as they already had the correct values in the DB. –  Krist van Besien Nov 1 '13 at 10:52
    
We don't know what you have tried unless you tell us. We're sysadmins, not mind readers. :) –  Michael Hampton Nov 1 '13 at 16:43
    
I've listed what I've tried so far in my question. –  Krist van Besien Nov 5 '13 at 11:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.