Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'am wondering that how can integrate my database,web,backup etc.. centos servers with Zimbra LDAP Server. Does it require more advanced configuration than standart ldap authentication ?

My zimbra server version is

[zimbra@zimbra ~]$ zmcontrol -v
Release 8.0.5_GA_5839.RHEL6_64_20130910123908 RHEL6_64 FOSS edition.

My LDAP Server status is

[zimbra@ldap ~]$ zmcontrol status
    ldap                    Running
    snmp                    Running
    stats                   Running
    zmconfigd               Running

I already installed nss-pam-ldapd packages to my servers.

[root@www]# rpm -qa | grep ldap

My /etc/nslcd.conf is

[root@www]# tail -n 7 /etc/nslcd.conf
uid nslcd
gid ldap
# This comment prevents repeated auto-migration of settings.
uri ldap://
base dc=domain,dc=com
binddn uid=zimbra,cn=admins,cn=zimbra
bindpw **pass**
ssl no
tls_cacertdir /etc/openldap/cacerts

When i run

[root@www ~]# id username
id: username: No such user

But i am sure that username user exist on ldap server.

EDIT : When i run ldapsearch command i got all result with credentials and dn.

[root@www ~]# ldapsearch -H ldap:// -w **pass** -D uid=zimbra,cn=admins,cn=zimbra -x 'objectclass=*'

# extended LDIF
# LDAPv3
# base <dc=domain,dc=com> (default) with scope subtree
# filter: objectclass=*
# requesting: ALL

dn: dc=domain,dc=com
zimbraDomainType: local
zimbraDomainStatus: active
share|improve this question
can you check your /etc/nsswitch.conf? I believe modern centos use sssd, not nslcd. – Francesco Malvezzi Oct 25 '15 at 10:51

If your zimbra server has multiple domains your base needs to be:


You need to set your ldap to target users by uid

share|improve this answer
How can i set my ldap to target users by uid? Can you answer it more spesific? – efesaid Nov 4 '13 at 13:12
My mistake, you already set your uid to nscld. Try changing gid to nscld, too. Change your base as I mentioned in my answer and try again. – Sibin Grasic Nov 5 '13 at 3:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.