Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'am wondering that how can integrate my database,web,backup etc.. centos servers with Zimbra LDAP Server. Does it require more advanced configuration than standart ldap authentication ?

My zimbra server version is

[zimbra@zimbra ~]$ zmcontrol -v
Release 8.0.5_GA_5839.RHEL6_64_20130910123908 RHEL6_64 FOSS edition.

My LDAP Server status is

[zimbra@ldap ~]$ zmcontrol status
Host ldap.domain.com
    ldap                    Running
    snmp                    Running
    stats                   Running
    zmconfigd               Running

I already installed nss-pam-ldapd packages to my servers.

[root@www]# rpm -qa | grep ldap
nss-pam-ldapd-0.7.5-18.2.el6_4.x86_64
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
pam_ldap-185-11.el6.x86_64
openldap-2.4.23-32.el6_4.1.x86_64

My /etc/nslcd.conf is

[root@www]# tail -n 7 /etc/nslcd.conf
uid nslcd
gid ldap
# This comment prevents repeated auto-migration of settings.
uri ldap://ldap.domain.com
base dc=domain,dc=com
binddn uid=zimbra,cn=admins,cn=zimbra
bindpw **pass**
ssl no
tls_cacertdir /etc/openldap/cacerts

When i run

[root@www ~]# id username
id: username: No such user

But i am sure that username user exist on ldap server.

EDIT : When i run ldapsearch command i got all result with credentials and dn.

[root@www ~]# ldapsearch -H ldap://ldap.domain.com:389 -w **pass** -D uid=zimbra,cn=admins,cn=zimbra -x 'objectclass=*'

# extended LDIF
#
# LDAPv3
# base <dc=domain,dc=com> (default) with scope subtree
# filter: objectclass=*
# requesting: ALL
#

# domain.com
dn: dc=domain,dc=com
zimbraDomainType: local
zimbraDomainStatus: active
.
.
.
share|improve this question

1 Answer 1

If your zimbra server has multiple domains your base needs to be:

ou=people,dc=domain,dc=tld

You need to set your ldap to target users by uid

uid=%uid
share|improve this answer
    
How can i set my ldap to target users by uid? Can you answer it more spesific? –  efesaid Nov 4 '13 at 13:12
    
My mistake, you already set your uid to nscld. Try changing gid to nscld, too. Change your base as I mentioned in my answer and try again. –  Sibin Grasic Nov 5 '13 at 3:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.