Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 8.1 x64 image that I sysprep'd and captured onto a Windows 2008R2 WDS server. When attempting to install it on a fresh client, the first action "Copying Windows Files" happens in about 2 seconds, showing a successful green checkmark. Then the second action (Getting files ready for installation) ends up displaying the following message:

Windows cannot install required files. Make sure all files required for installation are available, and restart the installation.

I have read through a lot of forums, and the closest I found was someone had the same issue because there was a file called WinPEPGE.sys was lodged in the image. But even that didn't show a symptom of the files being copied in a matter of seconds.

Two facts that might be pertinent: The client I am installing to is a non-UEFI (BIOS) system so the partitions being created in the unattend.txt do not include a EFI type partition. Also, the first system that Windows 8.1 was originally installed, sysprep'd, and captured from was a UEFI system.

Here is the setuperr.log that I pulled from the drive being installed to:

2013-11-01 17:11:22, Error      [0x0b0039] WDS    GetAdaptersAddresses failed; result:0x0000006f status:0x8007006f
2013-11-01 17:11:22, Error      [0x0b003b] WDS    QueryAdapterStatus failed (status 0x8007006f); will retry
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:11:23, Error      [0x0b003a] WDS          [gle=0x0000276d]
2013-11-01 17:12:18, Error      [0x0600a7] IBS    MoveOldOSFiles:Failed to move [C:\$WINDOWS.~BT\] to [C:\Windows.old\$WINDOWS.~BT\].[gle=0x00000005]
2013-11-01 17:12:18, Error      [0x06009d] IBS    DeployImage:MoveOldOSFiles failed; hr = 0x80070005[gle=0x00000005]
2013-11-01 17:12:18, Error      [0x060082] IBS    Callback_ImageTransfer:Failed to lay down the OS image; hr = 0x80070005[gle=0x00000005]
share|improve this question
up vote 2 down vote accepted

I had run a refresh on the operating system because I was having issues sysprep'ing it. I had deleted the windows.old folder that was left over, but I didn't realize that it also creates a $WINDOWS.~BT folder. This is also the folder that WinPE uses from WDS to perform the windows installation from. Because this folder existed in the .WIM image, it was attempting to move this folder into Windows.old before starting the install. This of course, failed.

I fixed it by following these steps:

  1. Stop the WDS service
  2. Mount the WIM image using ImageX.exe: ImageX.exe /mountrw image.wim 1 c:\mounted_image
  3. Delete the c:\mounted_image\$WINDOWS.~BT folder and all subfolders.
  4. Unmount and recapture the changes using ImageX.exe: ImageX.exe /unmount /commit c:\mounted_image
  5. Restart the WDS service

This seemed to cure the problem, as the remaining install steps are running through successfully now.

share|improve this answer

This solved my problem!

I kept getting this error. Deleted image from WDS, created a new group, added image, still failed. I then created a brand new image. Still failed. Finally came across this fix!

Here is what I did:

Ran CMD PROMPT as admin

Mounted the wim using DISM command:

DISM /Mount-Wim /WimFile:C:\pathtoimage\myimage.wim /index:1 /MountDir:C:\test\offline

Image is now mounted in folder C:\test\offline.

Deleted the $Windows~.BT folder from image.

Unmounted wim saving changes with /commit command:

Dism /Unmount-WIM /MountDir:C:\test\offline /Commit

Loaded image back into WDS

WORKED GREAT!!!

share|improve this answer
    
Same answer. This one uses DISM instead of ImageX, but they are both performing the same functionality. – Brain2000 Nov 3 '15 at 18:29
    
@Brain2000 true, but DISM will be present on any Windows Deployment server - ImageX will only be present and available on the command line if WAIK has been installed. – BE77Y Nov 17 '15 at 10:09

I've used DISM command-line tool to delete the hidden $WINDOWS.~BT folder and it worked. I did experience some problems with dism when running unmount and commit commands the same time. My advies is, run the commit (save changes) command fist before unmounting the image. https://technet.microsoft.com/en-us/library/hh825258.aspx

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.