Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a NFS server, A, that's sharing out a folder. B is mounting the the folder. B is also sharing that folder out. However C is unable to mounted it. The error on C is:

mount.nfs: failed, reason given by server: Permission denied

And on B the error in /var/log/messages is

Aug 17 15:21:21 B mountd[26140]: authenticated mount request from for /export/myfolder (/export/myfolder)
Aug 17 15:21:21 B mountd[26140]: Cannot export /export/myfolder, possibly unsupported filesystem or fsid= required

/etc/fstab on C: /mnt/myfolder   nfs  defaults,nodev,rsize=32768,wsize=32768,nfsvers=3   0       0

/etc/exports on B:


I've added the fsid argument to the exports, but still the same problem occures,

share|improve this question
why not share it from A? – Chopper3 Aug 17 '09 at 14:33
We need to see /etc/exports on the server, please. And the mount command line/fstab entry. – Chad Huneycutt Aug 17 '09 at 16:13

I'm curious why you wouldn't just want to share it from A (a network tunnel is much easier to configure) but in general you'll have a problem supporting both an nfs server and an nfs client on the same machine.

To fix your immediate problem, there's probably two things you can do. The first is to make sure that you're specifying an fsid other than 0 or whatever your fsid is set to on A. Second, since it looks like you might be using nfs4, have you mounted via a bind the volume into /exports, or is that a direct nfs mount of A's exported directory?

In my opinion, doing it this way looks like a major recipe for a failure and/or split brain condition when A and B get disconnected. You will probably also have permission and locking issues. It's REALLY not a good idea to do it this way.

share|improve this answer
I tried to add the fsid argument, but that didn't fix it. I've added the /etc/exports and /etc/fstab to the question. – Rory Aug 18 '09 at 10:09
The fsid needs to be a smaller number, IIRC. What's fstab on B look like? I can't remember with NFSv3 since I've been using 4, but I think you need to have a separate rpc_pipefs for both server and client ... On B, you can also try using the userspace nfs server instead of the kernel nfs server. Again, this is really a bad idea and I'd probably give up on making it work if I were you. – Karl Katzke Aug 18 '09 at 17:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.