Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have setup a LEMP server following the guide Install Nginx/PHP-FPM on Fedora 20/19, CentOS/RHEL 6.5/5.10.

It's been a while since I did the setup, so I wanted to grab the latest updates from REMI repository. I ran the following command:

yum --enablerepo=remi,remi-php55 update

I now get these dependency related errors:

# yum --enablerepo=remi update
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.nl.leaseweb.net
 * epel: mirror.1000mbps.com
 * extras: mirror.nl.leaseweb.net
 * remi: remi.schlundtech.de
 * updates: centos.mirror1.spango.com
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package chkconfig.x86_64 0:1.3.49.3-2.el6 will be updated
---> Package chkconfig.x86_64 0:1.3.49.3-2.el6_4.1 will be an update
---> Package glibc.x86_64 0:2.12-1.107.el6_4.4 will be updated
---> Package glibc.x86_64 0:2.12-1.107.el6_4.5 will be an update
---> Package glibc-common.x86_64 0:2.12-1.107.el6_4.4 will be updated
---> Package glibc-common.x86_64 0:2.12-1.107.el6_4.5 will be an update
---> Package gnupg2.x86_64 0:2.0.14-4.el6 will be updated
---> Package gnupg2.x86_64 0:2.0.14-6.el6_4 will be an update
---> Package iputils.x86_64 0:20071127-17.el6_4 will be updated
---> Package iputils.x86_64 0:20071127-17.el6_4.2 will be an update
---> Package kernel.x86_64 0:2.6.32-358.23.2.el6 will be installed
---> Package kernel-firmware.noarch 0:2.6.32-358.18.1.el6 will be updated
---> Package kernel-firmware.noarch 0:2.6.32-358.23.2.el6 will be an update
---> Package libgcrypt.x86_64 0:1.4.5-9.el6_2.2 will be updated
---> Package libgcrypt.x86_64 0:1.4.5-11.el6_4 will be an update
---> Package mysql-libs.x86_64 0:5.1.69-1.el6_4 will be updated
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64
---> Package mysql-libs.x86_64 0:5.5.34-1.el6.remi will be an update
---> Package nginx.x86_64 0:1.4.2-1.el6.ngx will be updated
---> Package nginx.x86_64 0:1.4.3-1.el6.ngx will be an update
---> Package php-pear.noarch 1:1.9.4-20.el6.remi will be updated
---> Package php-pear.noarch 1:1.9.4-23.el6.remi will be an update
---> Package php-pecl-jsonc.x86_64 0:1.3.2-1.el6.remi.1 will be updated
---> Package php-pecl-jsonc.x86_64 0:1.3.2-2.el6.remi will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-jsonc-1.3.2-2.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-jsonc-1.3.2-2.el6.remi.x86_64
---> Package php-pecl-mongo.x86_64 0:1.4.3-1.el6.remi.1 will be updated
---> Package php-pecl-mongo.x86_64 0:1.4.4-1.el6.remi will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-mongo-1.4.4-1.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-mongo-1.4.4-1.el6.remi.x86_64
---> Package php-pecl-sqlite.x86_64 0:2.0.0-0.3.svn313074.el6.remi.5 will be updated
---> Package php-pecl-sqlite.x86_64 0:2.0.0-0.4.svn332053.el6.remi.5.4 will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.4.x86_64
---> Package postgresql-libs.x86_64 0:8.4.13-1.el6_3 will be updated
---> Package postgresql-libs.x86_64 0:8.4.18-1.el6_4 will be an update
---> Package remi-release.noarch 0:6-2.el6.remi will be updated
---> Package remi-release.noarch 0:6.4-1.el6.remi will be an update
---> Package rsync.x86_64 0:3.0.6-9.el6 will be updated
---> Package rsync.x86_64 0:3.0.6-9.el6_4.1 will be an update
---> Package selinux-policy.noarch 0:3.7.19-195.el6_4.12 will be updated
---> Package selinux-policy.noarch 0:3.7.19-195.el6_4.18 will be an update
---> Package selinux-policy-targeted.noarch 0:3.7.19-195.el6_4.12 will be updated
---> Package selinux-policy-targeted.noarch 0:3.7.19-195.el6_4.18 will be an update
---> Package setup.noarch 0:2.8.14-20.el6 will be updated
---> Package setup.noarch 0:2.8.14-20.el6_4.1 will be an update
---> Package tzdata.noarch 0:2013c-2.el6 will be updated
---> Package tzdata.noarch 0:2013g-1.el6 will be an update
---> Package xinetd.x86_64 2:2.3.14-38.el6 will be updated
---> Package xinetd.x86_64 2:2.3.14-39.el6_4 will be an update
--> Running transaction check
---> Package compat-mysql51.x86_64 0:5.1.54-1.el6.remi will be installed
---> Package php-pecl-jsonc.x86_64 0:1.3.2-2.el6.remi will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-jsonc-1.3.2-2.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-jsonc-1.3.2-2.el6.remi.x86_64
---> Package php-pecl-mongo.x86_64 0:1.4.4-1.el6.remi will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-mongo-1.4.4-1.el6.remi.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-mongo-1.4.4-1.el6.remi.x86_64
---> Package php-pecl-sqlite.x86_64 0:2.0.0-0.4.svn332053.el6.remi.5.4 will be an update
--> Processing Dependency: php(zend-abi) = 20100525-x86-64 for package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.4.x86_64
--> Processing Dependency: php(api) = 20100412-x86-64 for package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.4.x86_64
--> Finished Dependency Resolution
Error: Package: php-pecl-jsonc-1.3.2-2.el6.remi.x86_64 (remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Installed: php-common-5.5.4-1.el6.remi.x86_64 (@remi-test)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.21-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-mongo-1.4.4-1.el6.remi.x86_64 (remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Installed: php-common-5.5.4-1.el6.remi.x86_64 (@remi-test)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.21-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-jsonc-1.3.2-2.el6.remi.x86_64 (remi)
           Requires: php(api) = 20100412-x86-64
           Installed: php-common-5.5.4-1.el6.remi.x86_64 (@remi-test)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.21-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.4.x86_64 (remi)
           Requires: php(zend-abi) = 20100525-x86-64
           Installed: php-common-5.5.4-1.el6.remi.x86_64 (@remi-test)
               php(zend-abi) = 20121212-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(zend-abi) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(zend-abi) = 20090626
           Available: php-common-5.4.21-1.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php(zend-abi) = 20100525-x86-64
Error: Package: php-pecl-mongo-1.4.4-1.el6.remi.x86_64 (remi)
           Requires: php(api) = 20100412-x86-64
           Installed: php-common-5.5.4-1.el6.remi.x86_64 (@remi-test)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.21-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
Error: Package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.4.x86_64 (remi)
           Requires: php(api) = 20100412-x86-64
           Installed: php-common-5.5.4-1.el6.remi.x86_64 (@remi-test)
               php(api) = 20121113-64
           Available: php-common-5.3.3-22.el6.x86_64 (base)
               php(api) = 20090626
           Available: php-common-5.3.3-23.el6_4.x86_64 (updates)
               php(api) = 20090626
           Available: php-common-5.4.21-1.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
           Available: php-common-5.4.21-2.el6.remi.x86_64 (remi)
               php(api) = 20100412-x86-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Any idea how to solve these errors? Am I missing a package? or is this a bug?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I've fixed the problem like this:

  1. yum --enablerepo=remi,remi-php55 update --skip-broken -y

  2. yum --enablerepo=remi,remi-php55 update --nogpgcheck -y (had a package not signed warning)

Now everything appears to be updated.

share|improve this answer
1  
Please mark your own answer as accepted (in order to reduce the number of unanswered questions on this site). –  Cristian Ciupitu Jun 21 at 9:46
    
sure no problem. done. –  Latheesan Oct 27 at 7:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.