Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I manage a small "cluster" of 4 Xeon machines with Intel boards in my lab. They are all plugged to a 5-port 3-Com switch with static IP addresses like 10.0.0.x.

They are all running OpenSuse 11.4 and their /home/ is served by one of the machines (node00) via NFS. They are plugged to an UPS that can keep them on for ca. 15 minutes, but there are lots of electric shortages due to "unscheduled maintenace" that are longer than this. So they end up being powered down without notice.

If I set the BIOS to turn them on after power shortages, the issue is that they all boot at the same time and, if node00 decides to run fsck in the /home/ partition, it does not finish booting before the others try to NFS mount their /home/.

I am trying to make wake on lan work, so I can choose to boot the NFS clients only after the server has successfully booted. The problem is that when I run ethtool I get an output like this:

Supports Wake-on: pumbag
Wake-on: g

Theoretically, it is set to wake on MagicPacket(tm), according to the manual. But sending the WOL packet using wol -i 10.0.0.255 $MACADDR does not wake up the box after I shut it down with halt. The ethernet link led blinks after I send the packet, so it appears to be getting to the machine.

However, if I set it up with ethtool -s eth1 wol bag, the machine always wakes up right after halting, even if I don't send the Magic packet. This means that the device can wake up with LAN activity, but seems to be ignoring the magic packet. Setting wol ag does not wake the box with the MagicPacket.

Does setting wol a mean that it should boot with any broadcast message?

How can I diagnose the issue of the machine not waking up with the MagicPacket even though I am sending it and it's set up to wake up with it?

Thanks in advance!

share|improve this question
add comment

1 Answer 1

Wake-on-LAN (WOL) needs to be supported by both the network interface card and the BIOS of the system. ethtool only displays the NIC capabilities, not how the BIOS is configured. That might be your problem.

Although your approach is interesting I would recommend an alternative approach. Your problem is that the /home export may not be available when a server boots and this will disrupt the boot process.

Have you looked at the automounter autofs? That will mount the NFS share when it is actually accessed, in the case of home directories they will only be mounted on-demand when a user logs on. Ubuntu Autofs section 5.2 has an example for home directories.

share|improve this answer
    
Well, the BIOS setup does not show any option regarding WOL. The closest thing is an option to enable os risable the NIC's ROM and the help text mentions that if the ROM is disabled, the box won't be able to wake on lan. Of course I kept it enabled. Also, I believe that it is enabled because setting wol a with ethtool makes the machine boot immediately after it was halted. I may take a look on autofs, though. Thanks. –  Elton Carvalho Nov 5 '13 at 14:19
    
In some of the screenshots I found WOL is called remote wake up, wake-up by PCI card, PME event wake up and possibly some other variations too. –  HBruijn Nov 5 '13 at 14:40
    
Yes, I looked for most synonyms, but couldn't find any relevant option. Also, setting wol a makes the machine boot, the problem is that I can't control these events so finely as I would with the Magic Packet. –  Elton Carvalho Nov 5 '13 at 16:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.