Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed phpMyAdmin on my VPS LAMP server (Debian Squeeze/Apache2/MySQL/PHP5), but am unable to access it: //my-ip/phpmyadmin/ and //my-domain/phpmyadmin/ both produce the following error message: "No input file specified".

The phpMyAdmin FAQ identifies this as a permission problem, but the suggested solution seems not to apply to my situation. Every other solution I have come across involves removing/purging and reinstalling phpmyadmin - which I have done several times, always to the same result. Previous posts in this forum typically relate to Nginx, which I have not installed.

Thanks in advance for any help!

share|improve this question
    
maybe a dumb question, does "/etc/phpmyadmin/htpasswd.setup" exist? –  user16081-JoeT Nov 5 '13 at 18:11
    
It does, with "admin" as sole user. –  guiltybyintent Nov 5 '13 at 19:06

1 Answer 1

up vote 0 down vote accepted

I have now found the solution to my problem. The error log revealed a fastCGI-error:

FastCGI: server "/var/lib/apache2/fastcgi/php5.fastcgi" stderr: Unable to open primary script: /usr/share/phpmyadmin/index.php (No such file or directory)

However, the file did exist, and according to another serverfault thread this could be due to the doc_root parameter in php.ini. Commenting out doc_root resolved the issue (I had it set to /var/www). Hopefully, this may be useful to other forum readers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.