Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Can anyone tell me why inter vlan routing is working for all vlans except my newly created vlan 4/ I have an hp procurve 2610. Any help would be appreciated. I have basically this 1 switch with all unmanaged switches attached to the core. We have a second 2610 on port 28

Running configuration:


; J9085A Configuration Editor; Created on release #R.11.25

hostname "Core_HP"
interface 22
   speed-duplex 100-full
exit
ip routing
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-12,17-22,26-27
   ip address 192.168.4.6 255.255.255.0
   no untagged 13-16,23-24,28
   exit
vlan 2
   name "WAN"
   untagged 28
   ip address 10.254.254.3 255.255.255.0
   exit
vlan 3
   name "Wireless"
   untagged 13-16,24
   ip address 192.168.7.6 255.255.255.0
   ip helper-address 192.168.4.2
   tagged 27
   exit
vlan 35
   name "guest"
   untagged 23
   tagged 24
   exit
vlan 4
   name "esxi"
   untagged 25
   ip address 10.10.1.1 255.255.248.0
   exit
ip route 192.168.5.0 255.255.255.0 10.254.254.1
ip route 192.168.6.0 255.255.255.0 10.254.254.1
ip route 0.0.0.0 0.0.0.0 192.168.4.10


show ip route


                        IP Route Entries

  Destination        Gateway         VLAN Type      Sub-Type   M
etric     Dist.
  ------------------ --------------- ---- --------- ---------- -
--------- -----
  0.0.0.0/0          192.168.4.10    1    static               1
          1
  10.10.0.0/21       esxi            4    connected            0
          0
  10.254.254.0/24    WAN             2    connected            0
          0
  127.0.0.0/8        reject               static               0
          250
  127.0.0.1/32       lo0                  connected            0
          0
  192.168.4.0/24     DEFAULT_VLAN    1    connected            0
          0
  192.168.5.0/24     10.254.254.1    2    static               1
          1
  192.168.6.0/24     10.254.254.1    2    static               1
          1
 192.168.7.0/24     Wireless        3    connected            0
          0

show ip 

 Internet (IP) Service

  IP Routing : Enabled


  Default TTL     : 64
  Arp Age         : 20

  VLAN         | IP Config  IP Address      Subnet Mask     Prox
y ARP
  ------------ + ---------- --------------- --------------- ----
-----
  DEFAULT_VLAN | Manual     192.168.4.6     255.255.255.0   No

  WAN          | Manual     10.254.254.3    255.255.255.0   No

  Wireless     | Manual     192.168.7.6     255.255.255.0   No

  esxi         | Manual     10.10.1.1       255.255.248.0   No

  guest        | Disabled

I cannot ping 10.10.1.1 from 192.168.4.22 or any host on that vlan and from the vlan I cannot ping 192.168.4.10 or 192.168.4.22 So what gives?

When I say not working, what I mean is not routing to the new vlan. Connected to 25 is a dumb switch (trend net) 80$ switch. Within the vlan i can ping 10.10.1.1 and it works. I can ping a host on the vlan with a 10.10.1.2 address.

share|improve this question
1  
Insufficient information, but if I take a stab in the dark if you can currently ping between hosts on vlans 1 and 3 but not 1 and 4 then hosts on vlan 1 either have static routes back to the HP switch IP of 192.168.4.6 for the ip range 192.168.7.0/24, or the WAN router at 192.168.4.10 has a static route pointing to the HP switch for 192.168.7.6/24, and you've missed the static route you need on the desktop computers or wan router as appropriate to enable hosts to know how they're supposed to get to 10.10.1.1 –  Phil Nov 6 '13 at 16:21
    
Phil, phil was right here folks ;-) –  user19039 Dec 9 '13 at 18:34

1 Answer 1

up vote 3 down vote accepted

Converting my comment to an answer: (Thanks for the update, user19039!)

If I take a stab in the dark if you can currently ping between hosts on vlans 1 and 3 but not 1 and 4 then hosts on vlan 1 either have static routes back to the HP switch IP of 192.168.4.6 for the ip range 192.168.7.0/24, or the WAN router at 192.168.4.10 has a static route pointing to the HP switch for 192.168.7.6/24, and you've missed the static route you need on the desktop computers or wan router as appropriate to enable hosts to know how they're supposed to get to 10.10.1.1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.