Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm setting up my ruby production server based on CentOS 6. I need a process called god (which is a process monitoring tool) to start at boot. I'm using an init script that I found here. Just as stated in the guide I ran:

chkconfig --add god 

and then

chkconfig --level 345 god on

After this if I run "service god start|restart" everything works. It loads the available configurations and brings up the related processes (if they are not running).

Problem is it doesn't work at boot. If I reboot the system, then I do "ps -aux | grep god". At this point "god" is running but apparently it didn't load the configuration files.

If i run again service god restart, it loads everything without problems.

What am I doing wrong?

share|improve this question
Check all your relevant logs first. – Michael Hampton Nov 6 '13 at 20:08
sudo /sbin/chkconfig --level 345 god on; sudo chkconfig --list god – dmourati Nov 6 '13 at 21:02
@dmourati this is a RedHat-clone, not a Debian one. – Nils Nov 6 '13 at 21:51
@Nils chkconfig is a redhat utility, not a debian one. – dmourati Nov 7 '13 at 0:40
@dmourati sudo is normally not needed on a root shell. – Nils Nov 7 '13 at 21:25

The most propable reason for this is that there is a path missing during the boot-process.

Also check the shell that is being called in the first line of the init-script.

It should read:


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.