Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have just flattened my machine and installed Windows 8.1 Enterprise Edition.

I have used the Hyper-V to create a virtual machine for my Software Development stuff, on my VM I have also installed Windows 8.1 Enterprise Edition. I want to have two screen support when using this VM (not using /span)

Both the Hyper-V viewer and Remote Desktop give me a tickbox to "Use all my monitors for the remote session". However even with it ticked (and even when I tried the /multimon switch on the command line), I only get a single screen.

Am I missing something - this should be supported in Enterprise edition, right? Is there some extra config I need to do on the RDP host?

Forgive me if it's an obvious question, I'm more a developer and just stumbling through ;-)

Cheers! Ben

share|improve this question
    
Superuser might be a better place to ask this. –  Atilla Filiz Nov 7 '13 at 9:41
    
    
@jscott I stand corrected. –  Atilla Filiz Nov 7 '13 at 13:08

1 Answer 1

this http://blogs.msdn.com/b/rds/archive/2009/07/01/using-multiple-monitors-in-remote-desktop-session.aspx talks about setting up and also the limits for multimon for RDS on win7 and server 2008r2 - might apply here?

There are a few settings associated with the Remote Desktop Multimon feature that can be used to restrict the number of monitors and resolution that clients use to connect.

Restricting the maximum number of monitors:

The Remote Desktop Multimon feature provides an option to restrict the number of monitors a user can use to connect. By default, RDP protocol supports a maximum of 16 monitors. This number can be restricted to any value between 1 and 16 using one of the following three approaches: 1.Using the “Limit maximum number of monitors per session” setting in the Remote Desktop Configuration Tool (tsconfig.msc) as shown below: enter image description here 2.Setting the “Limit maximum number of monitors” machine group policy as shown below:

enter image description here 3.By setting the MaxMonitors property in the Win32_TSClientSetting WMI class (http://msdn.microsoft.com/en-us/library/aa383778(VS.85).aspx).

share|improve this answer
    
Good effort, but all this info seems to be about restricting the maximum number of monitors, not enabling a new one. I'm not able to reproduce the problem, as ticking the "Use all monitors..." checkbox works for me when RDP'ing to a Win 8.1 virtual machine. –  Ryan Ries Nov 7 '13 at 14:25
    
Thank you for the suggestions - I tried option 2, amending it in group policy, I enabled the policy and set it to 16 monitors (hah, I wish) but sadly, still only uses one of my screens. Thank you again for the attempt! :) –  bgs264 Nov 7 '13 at 16:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.