Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an external SMTP provider: auth.smtp.1and1.co.uk

I am trying to send SQL Server Reporting Services emails via this on an Windows 2012 Azure VM.

It is configured sufficiently correctly for emails to be generated, but I've not configured something or mis-configured something as the emails then stay in the queue.

Setup details

Configured SMTP Virtual Server

General: IP Address: Fixed value
Access: Access Control: Authentication: ticked Anonymous access
Access: Connection Control: All except the list below (which is empty)
Access: relay restrictions: Only the list below (which contains 127.0.0.1), ticked 'allow all..' option
Delivery: Outbound Security...:Basic Authentication with username and password completed, ticked TLS encryption
Delivery: Outbound connections...:TCP port=587
Delivery: Advanced: FQDN=ServerName, smarthost=auth.smtp.1and1.co.uk

I then set the following SSRS rsreportserver.config values:

<SMTPServer>100.92.192.3</SMTPServer>
<SendUsing>2</SendUsing>
<SMTPServerPickupDirectory> c:\inetpub\mailroot\pickup </SMTPServerPickupDirectory>
<From>tickets@sqlrelay.co.uk</From>

Tried so far

1) turning the smtp service off and on again (just in case)

2) run SMTPDiag with no errors (also no emails)

3) tried turning off the firewall for the ports (and more generally to see if it made a difference)

4) tried generation from powershell which resulted with message in queue

5) added 25 and 857 as endpoint

6) perused the event log and found some warnings that appear to be about the recipient

Message delivery to the remote domain 'gmail.com' failed for the following reason: Unable to bind to the destination server in DNS. 
Message delivery to the host '212.227.15.179' failed while delivering to the remote domain 'gmail.com' for the following reason: The remote server did not respond to a connection attempt.

7) tried pinging but this appears to be blocked on azure

8) tried more powershell sending on different domains variants (localhost, boxname, internal ip used in smtp properties, 127.0.0.1) - none resulting in success

9) tried adding a remote domain - no change

Could anyone recommend what step 10 should be in fixing this issue please?

share|improve this question

1 Answer 1

In the end I changed the SMTP host to one that did not require authentication and could impersonate the required email address.

Will leave this open for a while to see if anyone can contribute a more useful answer for this situation to aid anyone who lands on this in the future.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.