Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am following the below link to setup remote desktop over ssh using putty. "http://m.desy.de/sites2009/site_m/content/e262/e96318/RDPusage.pdf"

But, i am not able to connect to my remote server because my remote desktop fails.Could you please throw some light on this issue. Is there any ports that have to be opened on my local pc. I have configures firewall on windows side.

share|improve this question
    
do i need to install something on server side as well to enable the rdp over ssh ? –  shiva Nov 8 '13 at 6:57
    
You're not giving a whole lot to go on. What specifically is failing (putty, RDP returns host unreachable, etc..) What OS is the local system running, what version of windows is the server running? Can you remote into the server using just RDP or does that fail as well? Is RDP even set up on the remote server, or is the account your trying to use authenticated to open remote sessions? Are both machines on the same network segment? –  David V Nov 8 '13 at 7:43
    
rdp returns rdp cannot connect to the server. I have windows 7 on my pc .i can normally do an rdp to my server. But over putty i am not able to –  shiva Nov 8 '13 at 7:46

2 Answers 2

up vote 0 down vote accepted

If you can RDP into the server normally then we need to make sure that the server is accepting connections from the correct port. Check to verify both the Windows firewalls (and any network firewalls if applicable) are blocking incoming connections over port 1024 (replace with the port you used during setup.)

share|improve this answer
    
I am initiating a connection for my server on port 3389 and on my local firewall i have opened port 1024. –  shiva Nov 8 '13 at 8:03
    
should i be enabling port 1024 on the server –  shiva Nov 8 '13 at 8:15
    
No I don't believe so. From what I'm reading PuTTy is establishing the tunnel on your machine (hence the 'localhost:port') to an SSH proxy (bastion.desy.de in the example) so the remote server is still looking for for connections over 3389. The 1024 port is just used to tell PuTTy which session (server) it relays. Can you double check that you can establish a connection to the server you used under 'Host Name'? A ping should be just fine, establishing an ssh connection using PuTTy would be best. And just to verify you have PuTTy open while trying to RDP correct? –  David V Nov 8 '13 at 9:57
    
yes i am able to ping using the hostname. And yes i have putty open while trying to do an rdp. I am not able to do an rdp at all. on putty terminal i tried to connect to the server. The console opens and after entering the user id and passwd i get an access denied error. Sorry for too many questions. I am a newb –  shiva Nov 8 '13 at 10:14
    
in the above example i am using my rdp login credentials to login in putty –  shiva Nov 8 '13 at 10:16

Your question lacks details regarding what you have tried. A little more information on what parts of the connection are working/are not working, error messages and so on might help us help you diagnose your problem.

Nonetheless, here are some steps you can use for troubleshooting:

  • Verify that RDP is enabled on the server with netstat or Sysinternals' procexp.
  • Check that the host you are hopping over has TCP Forwarding enabled.
  • Check that the host you are running PuTTY on accepts connections on the local end ports (1024 and 1025 in the example).
  • Check that you didn't just type localhost in the server box the RDP client offers, but rather localhost:1024.
  • Check the firewall on all hosts, the one you are connecting from, the one you are connecting to and the one you are connecting over. Any one of them might drop packets. Perhaps the server is set up to refuse connections from the box you use for SSH login.
share|improve this answer
    
I am able to do an rdp to my server without putty. When i try with putty my rdp doesnt connect to the remote system.I have followed the document to configure the putty. I have also enabled the port 1024 on my local pc –  shiva Nov 8 '13 at 7:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.