Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently use Solusvm and xen

and I have a problem with xen-pv

there is a xen-pv template by default with the solusvm

Centos-5.3-x86

I have created a machine to test it but I have this error :

xm create -c vm103.cfg 
Using config file "./vm103.cfg".
Started domain vm103 (id=45)
                            Initializing cgroup subsys cpuset
Initializing cgroup subsys cpu
Linux version 3.4.58-1.el6xen.x86_64 (mockbuild@build.smartservermanagement.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-3) (GCC) ) #1 SMP Sun Aug 18 17:36:51 BST 2013
Command line: root=/dev/sda1 ro 
ACPI in unprivileged domain disabled
Released 0 pages of unused memory
Set 0 page(s) to 1-1 mapping
BIOS-provided physical RAM map:
 Xen: 0000000000000000 - 00000000000a0000 (usable)
 Xen: 00000000000a0000 - 0000000000100000 (reserved)
 Xen: 0000000000100000 - 0000000080800000 (usable)
NX (Execute Disable) protection: active
DMI not present or invalid.
No AGP bridge found
last_pfn = 0x80800 max_arch_pfn = 0x400000000
init_memory_mapping: 0000000000000000-0000000080800000
RAMDISK: 01cb9000 - 0431b000
NUMA turned off
Faking a node at 0000000000000000-0000000080800000
Initmem setup node 0 0000000000000000-0000000080800000
  NODE_DATA [mem 0x7ffec000-0x7fffffff]
Zone PFN ranges:
  DMA      0x00000010 -> 0x00001000
  DMA32    0x00001000 -> 0x00100000
  Normal   empty
Movable zone start PFN for each node
Early memory PFN ranges
    0: 0x00000010 -> 0x000000a0
    0: 0x00000100 -> 0x00080800
SFI: Simple Firmware Interface v0.81 http://simplefirmware.org
SMP: Allowing 4 CPUs, 0 hotplug CPUs
No local APIC present
APIC: disable apic facility
APIC: switched to apic NOOP
PM: Registered nosave memory: 00000000000a0000 - 0000000000100000
Allocating PCI resources starting at 80800000 (gap: 80800000:7f800000)
Booting paravirtualized kernel on Xen
Xen version: 4.1.5 (preserve-AD)
setup_percpu: NR_CPUS:16 nr_cpumask_bits:16 nr_cpu_ids:4 nr_node_ids:1
PERCPU: Embedded 27 pages/cpu @ffff88007fc00000 s81024 r8192 d21376 u524288
Built 1 zonelists in Node order, mobility grouping on.  Total pages: 517995
Policy zone: DMA32
Kernel command line: root=/dev/sda1 ro 
PID hash table entries: 4096 (order: 3, 32768 bytes)
Checking aperture...
No AGP bridge found
Memory: 2004608k/2105344k available (4238k kernel code, 448k absent, 100288k reserved, 2330k data, 912k init)
SLUB: Genslabs=15, HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
Hierarchical RCU implementation.
NR_IRQS:4352 nr_irqs:304 16
Console: colour dummy device 80x25
console [tty0] enabled
console [hvc0] enabled
allocated 8912896 bytes of page_cgroup
please try 'cgroup_disable=memory' option if you don't want memory cgroups
installing Xen timer for CPU 0
Detected 2493.784 MHz processor.
Calibrating delay loop (skipped), value calculated using timer frequency.. 4987.56 BogoMIPS (lpj=2493784)
pid_max: default: 32768 minimum: 301
Security Framework initialized
SELinux:  Initializing.
Dentry cache hash table entries: 262144 (order: 9, 2097152 bytes)
Inode-cache hash table entries: 131072 (order: 8, 1048576 bytes)
Mount-cache hash table entries: 256
Initializing cgroup subsys cpuacct
Initializing cgroup subsys memory
Initializing cgroup subsys devices
Initializing cgroup subsys freezer
Initializing cgroup subsys net_cls
CPU: Physical Processor ID: 0
CPU: Processor Core ID: 0
SMP alternatives: switching to UP code
ftrace: allocating 19575 entries in 77 pages
Performance Events: unsupported p6 CPU model 23 no PMU driver, software events only.
installing Xen timer for CPU 1
SMP alternatives: switching to SMP code
installing Xen timer for CPU 2
installing Xen timer for CPU 3
Brought up 4 CPUs
devtmpfs: initialized
Grant tables using version 2 layout.
Grant table initialized
dummy: 
NET: Registered protocol family 16
PCI: setting up Xen PCI frontend stub
bio: create slab <bio-0> at 0
ACPI: Interpreter disabled.
xen/balloon: Initialising balloon driver.
xen-balloon: Initialising balloon driver.
vgaarb: loaded
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: System does not support PCI
PCI: System does not support PCI
NetLabel: Initializing
NetLabel:  domain hash size = 128
NetLabel:  protocols = UNLABELED CIPSOv4
NetLabel:  unlabeled traffic allowed by default
Switching to clocksource xen
pnp: PnP ACPI: disabled
NET: Registered protocol family 2
IP route cache hash table entries: 65536 (order: 7, 524288 bytes)
TCP established hash table entries: 262144 (order: 10, 4194304 bytes)
TCP bind hash table entries: 65536 (order: 8, 1048576 bytes)
TCP: Hash tables configured (established 262144 bind 65536)
TCP: reno registered
UDP hash table entries: 1024 (order: 3, 32768 bytes)
UDP-Lite hash table entries: 1024 (order: 3, 32768 bytes)
NET: Registered protocol family 1
Trying to unpack rootfs image as initramfs...
Freeing initrd memory: 39304k freed
platform rtc_cmos: registered platform RTC device (no PNP device found)
audit: initializing netlink socket (disabled)
type=2000 audit(1377529544.296:1): initialized
HugeTLB registered 2 MB page size, pre-allocated 0 pages
VFS: Disk quotas dquot_6.5.2
Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
msgmni has been set to 3992
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
io scheduler noop registered
io scheduler deadline registered
io scheduler cfq registered (default)
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
pciehp: PCI Express Hot Plug Controller Driver version: 0.4
acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
Non-volatile memory driver v1.3
Linux agpgart interface v0.103
brd: module loaded
loop: module loaded
Fixed MDIO Bus: probed
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
uhci_hcd: USB Universal Host Controller Interface driver
i8042: PNP: No PS/2 controller found. Probing ports directly.
i8042: No controller found
mousedev: PS/2 mouse device common for all mice
rtc_cmos rtc_cmos: rtc core: registered rtc_cmos as rtc0
rtc_cmos: probe of rtc_cmos failed with error -38
xen_wdt: Xen WatchDog Timer Driver v0.01
xen_wdt: initialized (timeout=60s, nowayout=0)
EFI Variables Facility v0.08 2004-May-17
usbcore: registered new interface driver usbhid
usbhid: USB HID core driver
TCP: cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
Registering the dns_resolver key type
registered taskstats version 1
IMA: No TPM chip found, activating TPM-bypass!
XENBUS: Device with no driver: device/vbd/2049
XENBUS: Device with no driver: device/vbd/2050
XENBUS: Device with no driver: device/vif/0
drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Initializing network drop monitor service
Freeing unused kernel memory: 912k freed
dracut: dracut-004-303.el6
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised: dm-devel@redhat.com
Running in PV context on Xen v4.1.
udev: starting version 147
udevd (650): /proc/650/oom_adj is deprecated, please use /proc/650/oom_score_adj instead.
dracut: Starting plymouth daemon
blkfront: xvda1: flush diskcache: enabled
blkfront: xvda2: flush diskcache: enabled
Setting capacity to 4194304
xvda2: detected capacity change from 0 to 2147483648
Initialising Xen virtual ethernet driver.
dracut Warning: No root device "block:/dev/sda1" found

dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.


dracut Warning: Signal caught!

dracut Warning: Boot has failed. To debug this issue add "rdshell" to the kernel command line.
Kernel panic - not syncing: Attempted to kill init! exitcode=0x00000100

Pid: 1, comm: init Not tainted 3.4.58-1.el6xen.x86_64 #1
Call Trace:
 [<ffffffff81416d0e>] panic+0xc4/0x1d3
 [<ffffffff810419eb>] do_exit+0x3a5/0x82d
 [<ffffffff81041ef0>] do_group_exit+0x7d/0xa5
 [<ffffffff81041f2f>] sys_exit_group+0x17/0x1b
 [<ffffffff8141fa29>] system_call_fastpath+0x16/0x1b

the main container Centos6 64bit

the config file dor the machine :

## This configuration file was automatically generated
## by SolusVM on Mon Aug 26 15:05:40 2013

## Cfg type: XEN-PV-LOCAL-STORAGE

kernel     = '/boot/solus-vmlinuz'
ramdisk    = '/boot/solus-initrd.img'
#bootloader = '/usr/bin/pygrub'
extra      = ''
memory     = 2048
hostname   = 'vps03.xxxxx.com'
cpu_weight = 256
name       = 'vm103'
vif        = ['ip=192.254.79.12, vifname=vifvm103.0, mac=00:16:3e:f5:01:e2']
vnc        = 0
vcpus      = 4
vncviewer  = 0
serial     = 'pty'
disk       = ['phy:/dev/vg/vm103_img,sda1,w', 'phy:/dev/vg/vm103_swap,sda2,w']
root       = '/dev/sda1 ro'

the container is working well and I have created 2 Xen-HVM machines and they doing well

anybody can advice ?

another Q please : my server 16GB ram , Dual Xeon : how much vcpu, ram that I must allocate for Dom0 ???

share|improve this question

1 Answer 1

Your PV DomU is looking for xvda1 and xvda2 while your config defines sda1 and sda2 instead.

Second Question: Make it a question of its own. The answer depends mainly on what your Dom0 needs and whether you want to balloon out the Dom0 or give it a fixed amount of RAM.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.