Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

to clear the air centos 6.4? (maybe 6.3) as the server, running samba 4.0.10, trying to add a windows 7 client that has connectivity to the server.

this is what windows shouts as me as it mocks my dependence on network infrastructure.

"the network location cannot be reached."

  1. i have access to the domain contoller (dc)

  2. im using the dc as the domain name server (dns) already, and the name is correctly resolving, and it is correctly forwarding outbound traffic.

  3. i have nothing but self taught experience with active directory(ad) so if i am missing something obvious, please shout it out, but keep the verbal abuse to a minimum. i checked samba4DC + my error and found nothing relevant to my issue, if i missed something please point me in that direction.

  4. the weekend is just starting as i write this so i probably wont be back on to check this post for a day or three, but i might because this mystery is killing me.

i followed the samba4 as a dc guide here and i supplimented gaps with this

i have tested kerberos, ntp, and set my DC as the clock to sync to in my windows client and it appears to be a very small fraction of a second off so that shouldn't be it.

also, firewall and selinux are both off for testing.

i have also tried disabling ipv6, and cleared the registry of ipv6 records (allegedly the default samba4 as a DC runs as windows server 2003 which allegedly does not support or tolerate the existence of ipv6, fair warning, i heard this on the internet so it is probably a lie)

i have tried a few other things that i have forgotten because i have been doing this for a day and a half now.

ideas welcome. suggestions for alternatives are also welcome, as long as they are free. i was given a budget of $0 dollars and told to implement active directory (no prior knowledge of active directory at that point).

share|improve this question
up vote 2 down vote accepted

alright, so i actually solved this a week ago and just didn't make it back to update because i have been doing active directory things since then.

as it turns out my network adapter was losing its mind silently, i did a packet capture and read through all the packets and everything was fully functional, the entire process was successfully negotiated, so apparently something was dropping the information immediately after it happened.

after reinstalling samba4 and reconfiguring it as a DC the problem persisted.

so then i tested client failure by joining a different machine to the domain and shockingly it worked. (this wasnt step one because i dont have any spare machines to tinker with and reconfiguring someones account on the fly during the workday is less than appealing, luckily the conference room opened up so i had a couple hours to tinker on that machine)

so then i had the issue of making my machine connect to it, so i slammed my meat-paws onto my keyboard furiously trying to decided what was wrong.

the solution was to go into control panel > network and internet > network and sharing > change adapter settings > right click adapter > select properties > uninstalling everything except tcp ipv4 > reinstalling everything.

i am not sure which of the settings were non-functional because i am not super up on the protocols and i was impatient and foolish and tried all of them at once, but it was fixed when the dust settled.

as it turns out this is not so much a serverfault topic as i initially thought it might have been, so if it needs to be moved so be it, although someone may run into this problem again in the future and have no idea why joining the samba4 DC isnt working.

share|improve this answer
fantastic answer :) – Superbiji Feb 26 '14 at 7:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.