Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've inherited a DNS server setup and I'm trying to configure our local intranet properly. Forgive me if this is simple, but I'm missing something in our configuration.

We're hosting trying to host 2 separate intranet sites on 1 IIS 6 Server (Server 2003).

Site 1: http:// servername (ipaddress:80) Site 2: http:// production (ipaddress:8080) - host header value of 'production' in IIS and DNS A Record set up points to the correct server.

Everything works properly for a while, but unexpectedly we lose the ability to type in 'production' - and get a DNS resolver error.

If we cmd > ipconfig /flushDNS, everything works perfect back to normal.

Why would each of the clients be losing the reference and then not allowing us to connect for a period of time? (nslookup always finds the correct server, then it works fine again)

Is there any way to create a "static" reference without changing the HOSTS file on each PC (not practical).

Thanks in advance for your help!

share|improve this question
    
Also, I noticed that our "secondary dns" entry is a 4.2.2.2 (because we're only running one DNS server). Though nslookups are all going through our local server, could the PC be requesting the record from Verizon, and because its local not getting a response, then storing an incorrect record? Any ideas? Thanks again for the help. –  JBickford Sep 29 '09 at 15:40

3 Answers 3

up vote 2 down vote accepted

An A record is a static reference unless you're allowing dynamic updates. The fact that a /flushdns seems to fix the problem is a bit of a puzzler, as all that command does is clear the cache. Clearing the cache as a fix doesn't really make any sense unless the records themselves are changing (which is usually why one would want to flush the cache).

If this is a Windows DNS server, do you by chance have scavenging turned on? Failing that, are you running more than one DNS server and the zone is expiring?

You might experiment by turning off the dns cache on a couple of workstations to see if they then fail at the same time as the caching workstations.

"net stop dnscache" will deactivate caching until the next reboot.

edit: internally, we used to run about a 100 different A records all pointing to essentially the same resource which was an absolute nightmare if you ever had to change the resolution unless you were 100% sure of your sed/awk skills. Now I insist that they either utilize the standards that I've built, or a CNAME that points to the standards based A record. An example:

$ORIGIN mydomain.com.
socketalpha             CNAME   alpha.socket
socketbeta              CNAME   beta.socket
socketdvlp              CNAME   dvlp.socket
socketsystems           CNAME   systems.socket
alpha                   A       192.168.125.12
alphasecure             CNAME   alpha.secure
alphasecured            CNAME   alpha.secured
$ORIGIN secure.mydomain.com.
alpha                   A       192.168.125.32
beta                    A       192.168.125.33
dvlp                    A       192.168.125.31
systems                 A       192.168.125.30

The standard I push is ... You could probably find a more efficient method for your own setup, but using this means that if, for example, the server/virtual for alpha.socket.mydomain.com changes, I don't have to change multiple A records.

share|improve this answer
    
I'm going to try stopping the DNS Cache for a while on a few of the pcs, see if that isolates the problem. I'll let you know what I come up with. –  JBickford Sep 29 '09 at 15:38
    
Disabling the DNS Cache worked. Any suggestions on troubleshooting from there? Can't imagine that best practice would be to permanently disable DNS Cache... Thanks again. –  JBickford Oct 1 '09 at 13:55
    
are dynamic updates allowed to that zone? turn cache back on and then make sure you know what the records are resolving to when it breaks with nslookup or dig. We had what might have been a similar situation cause a 12 hour outage one day when the (at the time) backup Windows Oracle servers got restarted and refreshed the name that we were using to hit the production boxes. We now have a service level DNS zone where ALL "service" names are placed that is specifically a primary/secondary zone, not ADI. –  Greeblesnort Oct 1 '09 at 20:26
    
also, is "production" a CNAME to "servername"? your OP indicates that it is an A record, but if they're pointing to the same box, I would suggest switching that to a CNAME –  Greeblesnort Oct 1 '09 at 20:28
    
Thanks for your help! Interesting that you mentioned switching to CNAME, never occurred to me but might have done the trick. I've updated as such and haven't run into problems for a while (though I'm only switching DNS Cache back on now). I'll keep you posted but my assumption is that is the fix. Thanks again. –  JBickford Oct 28 '09 at 13:38

Are you running WINS? That may help resolve NetBIOS names.

You also might look at setting your search domain on clients, which I believe will automatically append your domain name to your server name in order to create a FQDN which your DNS server might resolve more easily.

share|improve this answer

If your using Host Headers isn't the idea to use the same port i.e port 80

share|improve this answer
    
Yes, actually, my mis-communication. I'm using the Host Header on port 80, and also binding 8080 so I can get there directly (since host header is only working half the time) –  JBickford Sep 29 '09 at 15:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.