Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

MOSS 2007 standard (no forms services)

I want to submit a form to a Form Library so that after the form is submitted, only the owner of the site and library can edit the form. Anybody can add or view, owners can edit or delete.

I have created a customer Permission Level that only allows Add Items and View Items, and trying to submit an InfoPath 2007 form to the library will successfully add a document to the library, but give the following error message to the user:

Error submitting the form. You can save a copy to your machine and process it manually later. details:

InfoPath cannot submit the form.

An error occurred while the form was being submitted.

The form cannot be submitted to the following location: http://space/xx/yyyy/zz/Test/TEST-276-2009-08-17.xml There is a problem with the Web server. Make sure the Web server exists, try again later or contact the Web server administrator.

So the users of course try again and again to submit the file, but it is already there.

If I allow Edit Items into the Permission Level it works as expected, but the business rules don't allow normal users to edit any files including their own.

Can this be accomplished without other intervention such as a custom workflow?

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Here is an MSDN forums topic that is very similar to yours. Basically, the result was that MS says SharePoint does a checkout/checkin once the form is submitted, which requires Edit permissions. A further post by Clayton Cobb outlines a possible workaround for the problem.

share|improve this answer
    
Thank you for at least pointing out why. I am afraid the workaround does leave open avenues, so it won't work for our situation. –  MrChrister Aug 17 '09 at 22:02
    
I was thinking about this last night and thought of something much simpler, but haven't had a chance to try it. Why not try turning off document checkout (and possibly document versioning) on the list to see if that helps fix the problem? –  MattB Aug 18 '09 at 13:35
    
Document checkout and versioning are both off already. That is why it is so frustrating that InfoPath chooses to check-in. –  MrChrister Aug 19 '09 at 16:41

One of the things we did - and it worked for us - although it doesn't "officially" prevent editing....

I allowed editing to be enabled - so submission worked as needed. Then, I created a view of the library that removed the edit options (believe it's document name without the edit menu - you'll see it) I then made this new view the default view. Now, a savvy user would know to go into an alternate view to access the edit options - but this keeps 99% of my casual end users from causing problems.

Not airtight - but for us it has worked well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.