Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to get a Windows 2008 R2 server to Wake On Lan (WOL), but I am failing. Before you ask the usual questions:

  • 1: YES - the hardware supports it (Dell Precision T3400)
  • 2: YES - the BIOS is set to allow it
  • 3: YES - it works with Windows 7
  • 4: YES - Control Panel settings are reviewed and look OK

The servers goes to sleep, and I cannot wake it up by sending network packets to it. When on Windows 7, this does not occur.

If Windows 2008 R2 does not support this, how can it be made to, ie: what can we use from Windows 7 to try to provide this support to Windows 2008 R2?

share|improve this question
2  
I wasn't aware that Windows 2008 will even go into sleep or hibernate mode... –  Mark Henderson Aug 17 '09 at 22:58
2  
Is there a reason your server sleeps? –  MDMarra Aug 17 '09 at 23:49
1  
Windows 2008 R2 probably doesn't support it as you wouldn't want your server going to sleep at all, much less being woken up. –  mrdenny Aug 18 '09 at 0:03
    
Do you know which sleep mode you're going into? S3? S4? –  Mark Henderson Aug 18 '09 at 0:57
    
Mrdenny, you may not want it to go to sleep but if it did, for whatever reason, it would be nice to be able to wake it up again. –  John Gardeniers Aug 18 '09 at 2:37
show 1 more comment

4 Answers

OK, as much as I really don't condone putting a server to sleep, check the following

  • Start
  • Control panel
  • Power
  • Just below the currently select plan, click "Change Plan Settings"
  • Click the link for "Change settings that are currently unavailable"
  • OK to the UAC
  • Changed Advanced Power Settings
  • In the list that is presented, locate your network card and look for a property called "Allow this device to wake the computer" - make sure it is set to Yes.

If you cannot find the setting there, check in the following location:

  • Start
  • Control Panel
  • System
  • Device Manager
  • OK to UAC
  • Locate your network card, right-click and go to Properties
  • Go to the Power Management tab
  • Tick "Allow this device to wake the computer"
  • Ensure that "Only allow management stations to wake the computer" is un-checked
share|improve this answer
1  
These steps are correct but I suspect the folks at dell didn't put the right drivers hooks in for server since the t3400 isn't supported under any server OS –  Jim B Aug 18 '09 at 1:48
    
Wouldn't surprise me either. Especially if it worked Out Of the Box on a desktop flavour of Windows. –  Mark Henderson Aug 18 '09 at 2:19
    
Actually gentlemen, you judge Dell too harshly. I choose Dell, and specifically their Precision line because of the very standard (and performant) hardware configurations. Dell Precisions (all models since 390 range onward) support Windows x64 OS's (all OS's), Linux and even VMware ESX/ESXi. All devices are regcognized and supported from standard OS distributions installs, no need for any OEM specific drivers, and I feel that it's more stable this way. All drivers are installed by OS distributions only. –  cmdematos.com Aug 18 '09 at 16:48
    
So I take it that the steps above did not solve your problem? –  Mark Henderson Aug 18 '09 at 21:02
    
Farseeker - thank you so much for your response. Just tried this and the settings were already setup like this, however this still does not wake the computer up. I will keep this open for a while and if no better answer comes along I will credit yours since I think then it will be a limitation perhaps in the OS itself. –  cmdematos.com Aug 18 '09 at 21:57
show 2 more comments
up vote 0 down vote accepted

I did more digging and this is what I found:

  • Windows 7 only wakes up when addressed by Windows Server - apparently Server sends a magic packet if it gets no response from the client OS.
  • *** Ping windows 7 did not wake it up. Just typing \windows7\c$ in the explorer address bar, without hitting enter - did.
  • Windows Server does not wake up another windows server.
  • *** Ping windows server from another server had no result. \server\c$ did not wake it up either - even when hitting enter. Sending a magic packet using a utility did wake it up succesfully.

Moral of the story: It seems that Windows Server is the active party in waking up the other party. A sleeping Windows Server can be woken up if it receives the magic packet.

So - since I keep one server on permanently that I run DHCP/DNS and my Linux Web server on VMware, I will build a web site with a simple selection menu that will wake up the other systems on demand.

Thank you all for your help - it was educational!

share|improve this answer
add comment

Search the web for utilities that send WOL (Wake On Lan) packet. There are a quite a few available, here is one example... http://www.matcode.com/wol.htm

I no longer run any Windows servers (Back then my lab was 5 quad core 8Gb Ram Dell Precision T3400's). Now I run two Ubuntu servers as my lab and any Windows machines are virtualized (and there are only two of these in any case). All my development work has migrated to Open Source software.

Cheers!

share|improve this answer
add comment

In addition to all the settings mentioned above you also have to make sure your connection is on the home or work network. If it is on public, which is the default unless you select one of the other two, WOL will not work.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.