Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I posted my question on stackoverflow but I was told that it might be better off here. I have a problem executing my SSI package from command line. I created the package via SQL Server Business Intelligence Studio while logged in as a domain administrator.

share|improve this question
More info and the error would be helpful. – Sam Jan 22 '10 at 0:26
up vote 1 down vote accepted

Another thing can you go to Start->Control Panel->Administrative Tools->Services and ensure you have a listing for SQL Server Integration Services.

If not you will need to go to Control Panel->Add/Remove Programs->SQL Server and change the options and ensure you have installed SSIS.

If the SSIS service is not installed you cannot run packages correctly and will get an error msg.

This may not be your particular problem but may just be as simple as this.

Update 1:

Can you confirm some of the following:

  1. You have deleted and redeployed the package to the server with your credentials?
  2. You have run the package successfully using the file option?

Also you could try the following command on the SQL server to reset the owner of the DTS package:

sp_reassign_dtspackageowner [@name =] 'name', [@id =] 'id', [@newloginname =] 'newloginname'
share|improve this answer
This service is present and started. – Saif Khan Aug 18 '09 at 15:58

A quick search returns plenty of possible causes for this error, such as this: SSIS Error from DTEXEC: Login timeout expired. Have you worked through these already?

share|improve this answer

On first glance this looks to be an authentication issue.

I would first ensure that you are using the correct command line syntax for the dtsexec utility. Consult the following Microsoft reference for full details.

share|improve this answer
My systax is all fine. It has to be authentication, but where? I am logged in as domain admin on the server. I an logged in to SQL Server via windows authentication. – Saif Khan Aug 18 '09 at 16:02

Look to see if it works when you use escalated privileges to run the Command Prompt. Ie, right-click on your Command Prompt shortcut and say "Run as administrator"

share|improve this answer

Are you trying to log into the SQL Server via TCP or named pipes? Are you able to use sqlcmd from the server's console?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.