Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows Server 2008 R2 running and I am able to connect to it using 2 different users via Remote Desktop Connection. Since a colleague and me are working on the server almost all the time and another colleague also wants to connect there is always the need to disconnect one user which is bad.

Is there a possibility to increase the number of allowed users? On another server there are more than 2 users allowed. What is different there?

share|improve this question
add comment

migrated from superuser.com Nov 10 '13 at 19:27

This question came from our site for computer enthusiasts and power users.

2 Answers

This is a licensing issue:

  • When remote desktop is used only to administer the server, no additional licenses are required but the number of simultaneous connections is limited to two.
  • When remote desktop is used to do normal business work on the server (eg running LOB application) or when more than 2 simultaneous connections is required, you need to buy additional Remote Desktop Services Client Access License either for each user that is accessing the server or for each device that is used to access the server (whichever option is cheaper or more comfortable for you)

See this TechNet article for details about RDS licensing. There's also a more detailed document available.

share|improve this answer
add comment

You need to install the RD Session Host role service. Then you can change the number of connections in the Remote Desktop Session Host Configuration under Connections/Properties/Network Adapter tab/Maximum connections. There is a Technet article describing this and also a second way to do it with a group policy.

share|improve this answer
    
Thank you for the link. I disabled the "Limit number of connections" option in the "Local Group Policy Editor". This still allows only 2 connections. Maybe I have to change the mode? –  gentlesea Nov 8 '13 at 10:38
1  
@gentlesea Did you also install the RD Session Host role service? –  Werner Henze Nov 8 '13 at 10:41
    
I found this: technet.microsoft.com/en-us/library/cc742813.aspx. This has to be done, correct? –  gentlesea Nov 8 '13 at 10:51
    
I just did this. Restart is pending... –  gentlesea Nov 8 '13 at 10:51
1  
Now you need to purchase RDS CAL's and install an RDS License server. –  joeqwerty Nov 8 '13 at 15:45
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.