Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm installing sql instances through script, and after creating a certain instance, I cannot get the sa account to be enabled through osql.

What I've tried

  1. osql -S .\INSTANCENAME -E
    use master
    ALTER LOGIN sa ENABLE
    GO

  2. Using SSMS to enable the account (by logging in using Windows Auth., 'New query', and exactly the same query as in 1.)

  3. Suggestions in this issue

No. 2. is actually working; and the account is enabled instantly. No 1 is not working, not even with the suggestions provided in 3., I have restarted the SQL services after executing the commands in osql.

Additional info
Windows 2003 Server, Microsoft SQL Server 2005 Enterprise, No password policies apply to the account.

share|improve this question
    
Do you get an error from #1? –  squillman Aug 18 '09 at 12:30
    
Chris' answer is likely the problem; when you install you need to specify mixed mode and set the password. If SA is disabled right after an install then mixed mode is not turned on. –  Jason Cumberland Oct 5 '11 at 14:34
add comment

2 Answers 2

You do not state, but the syntax .\instancename implies that you are running your OSQL on your target server? Is this the case? Have you tried Servername\instancename?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.