Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On our Citrix farm, I just found out that some sub-components are "Installed on 1st Use" (Advertised), which does play well on terminal servers.

Not only that, but you also get a rather non-descriptive error message, when a document tried to use a component, which is "Installed on 1st Use" (described on Plan to deploy Office 2010 in a Remote Desktop Services environment):

Microsoft Office cannot run this add-in. An error occurred and this feature is no longer functioning correctly. Please contact your system administrator.

I have ~50 Citrix servers where I need to change the installation state of all Advertised components to Local, so I created an XML file like this:

<?xml version="1.0" encoding="utf-8"?>
<Configuration Product="ProPlus">
    <Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />
    <Logging Type="standard" Path="C:\InstallLogs" Template="MS Office 2007 Install on 1st Use(*).log" />
    <Option Id="AccessWizards" State="Local" />
    <Option Id="DeveloperWizards" State="Local" />
    <Setting Id="Reboot" Value="NEVER" />
</Configuration>

I run it with a command like this (using the appropriate paths):

"[..]\setup.exe" /config ProPlus /config "[..]\Install1stUse-to-Forced.xml"

According to the log file, the syntax appears to be accepted and the config file parsed:

Parsing command line.
Config XML file specified: [..]\Install1stUse-to-Forced.xml
Modify requested for product: PROPLUS
Parsing config.xml at: [..]\Install1stUse-to-Forced.xml
Preferred product specified in config.xml to be: PROPLUS

But the "Final Option Tree" still reads:

Final Option Tree:
  AlwaysInstalled:local
  Gimme_OnDemandData:local
  ProductFiles:local
    VSCommonPIAHidden:local
    dummy_MSCOMCTL_PIA:local
    dummy_Office_PIA:local
    ACCESSFiles:local
...
      AccessWizards:advertised
      DeveloperWizards:advertised
...

And the components remain "Advertised".

Just to see if the installation state is overridden in another XML file, I ran:

findstr /l /s /i "AccessWizards" *.xml

Against both my installation source and "%ProgramFiles%\Common Files\Microsoft Shared\OFFICE12\Office Setup Controller", but just found DefaultState to be "Local".

What am I doing wrong?

Thanks!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.