Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install Debian 7.1 from DVD onto 2x500GB drives which are set up in a FakeRAID mirror using the on-board FakeRAID provided by the Z77 chipset.

I have followed the guide here https://wiki.debian.org/DebianInstaller/SataRaid. Namely, I booted into the expert install with the 'dmraid=true' option added, installed onto the RAID mirror which the installer correctly detected, then installed grub2 onto /dev/mapper/.. raid volume. I chose to use LVM (so a boot partition + LVM volume).

As per the guide, I have uncommented the "GRUB_DISABLE_LINUX_UUID=true" line in "/etc/default/grub" and ran "update-grub" then "grub-install /dev/mapper/.." (with the right RAID device in the command).

However, after I rebooted the system, all I got was a grub console. It did not load the menu. I checked and it seems that it never even generated a menu file. I re-installed Debian a few times since, trying out different options and also a few workarounds people posted online, but to no avail. The best I am getting is a grub console. No menu. Some times it will generate the grub.cfg, some times it won't, depending on the workaround I try.

I was wondering if anyone else has experienced this issue. There is no need to preach how I should not use FakeRAID. I have seen others trying to figure this out so I think a resolution to this issue would be of interest to more than just me.

Also, I first installed the system onto a small drive for testing something else. I made a backup with Acronis and was able to restore that onto the RAID mirror by using Universal Restore. When I installed it onto a 500GB without RAID, backed up using the same method, then restored onto a RAID volume of the same size, it would not boot and I got grub errors. Weird.

I can post more details, just let me know what you want to see.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.