Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm using Apache 2 on Ubuntu 12.04.

I added an alias for a subdirectory, to point to gitweb. I realised I should probably make it accessible only on https - so I removed the alias and restarted Apache.

I can still navigate to http://xyz/gitweb - even with no alias in any of my config files. How do I remove it?

EDIT

The config file looked like this before:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /home/administrator/webroot
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/administrator/webroot/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        Alias /gitweb/ /usr/share/gitweb/
        <Directory /usr/share/gitweb/>
                Options ExecCGI +FollowSymLinks +SymLinksIfOwnerMatch
                AllowOverride All
                order allow,deny
                Allow from all
                AddHandler cgi-script cgiDirectory
                Index gitweb.cgi
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

And this after:

<VirtualHost *:80>
        ServerAdmin webmaster@localhost

        DocumentRoot /home/administrator/webroot
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /home/administrator/webroot/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog ${APACHE_LOG_DIR}/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
share|improve this question
    
did you reload apache? Can you provide config file? –  aif Nov 12 '13 at 8:27
    
As mentioned in the question - I restarted apache. There's no hint of the alias in the config file now. so there's not much to provide, but I've added what I did to the question –  Hippyjim Nov 12 '13 at 9:56
    
Are you sure you're not looking at page cached by your browser? –  Teun Vink Nov 12 '13 at 10:28
    
Yeah, thanks, I thought of that too. I switched browsers, and even tried another PC. It's definitely still live. –  Hippyjim Nov 12 '13 at 10:31

1 Answer 1

I'm an idiot.

The gitweb installer had added a file to /etc/apache2/conf.d/ that added the alias.

Thanks all for looking.

Anyone who as similar weirdness, check that folder for unexpected configs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.