Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When attempting to add a dataset in Report Builder I am prompted to "Enter Data Source Credentials."

enter image description here

Choosing "Use the current Windows user" fails, and I don't have the password for the specified user.

  • The environment is SCCM 2012.
  • What permissions need to be changed so that I may access the SCCM datasource?
  • What are best practices for giving users RW access to reports in SCCM/SSRS?
share|improve this question

1 Answer 1

up vote 2 down vote accepted

The solution was two-fold:

  1. I exported the certificate from the primary site sever under "Personal\Certificates" the friendly name is "ConfigMgr SQL Server Identification Certificate." I then imported the certificate to my local workstation under "Trusted Root Certificate Authorities\Certificates." This allowed me to connect to SQL server when I choose "Use the current Windows user." Before I made this change I would get a certificate error when choosing this option.
  2. I had the DBA enable db_datareader access explicitly for my user in SQL Server.

When creating a dataset I still was prompted for credentials but I can now select current user and create queries.

share|improve this answer
    
I had this same issue and found this to be the only solution as well. Did you get this from Microsoft PSS/CSS? I'm really curious to see why they went this direction. –  Jason Cumberland Nov 18 '13 at 18:00
1  
Here are the references. Certificates:thecmadmin.com/2013/07/22/… Permissions: windows-noob.com/forums/index.php?/topic/… –  Bin Nov 19 '13 at 12:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.