Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Whenever i try to send an email from my server, i get the following error:

Nov 13 06:37:21 xyz postfix/smtpd[6730]:connect from unknown[a.b.c.d]
Nov 13 06:37:21 xyz postfix/smtp[6729]: warning: host X.com[x.y.z.d]:25 greeted me with my own hostname xyz.biz
Nov 13 06:37:21 xyz postfix/smtp[6729]: warning: host X.com[x.y.z.d]:25 replied to HELO/EHLO with my own hostname xyz.biz
Nov 13 06:37:21 xyz postfix/smtp[6729]: 2017F1B00C54: to=<dummy@X.com>, relay=X.com[x.y.z.d]:25, delay=0.98, delays=0.17/0/0.81/0, dsn=5.4.6, status=bounced (mail for X.com loops back to myself)

this is the output of postconf -n:

address_verify_poll_delay = 1s
alias_database = hash:/etc/aliases
alias_maps =
body_checks_size_limit = 40980000
command_directory = /usr/sbin
config_directory = /etc/postfix
connection_cache_ttl_limit = 300000s
daemon_directory = /usr/libexec/postfix
data_directory = /var/lib/postfix
debug_peer_level = 1
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin ddd $daemon_directory/$process_name $process_id & sleep 5
default_delivery_slot_cost = 2
default_destination_concurrency_limit = 10
default_destination_recipient_limit = 1
default_minimum_delivery_slots = 3
default_process_limit = 10000
default_recipient_refill_delay = 1s
default_recipient_refill_limit = 10
disable_dns_lookups = yes
enable_original_recipient = no
hash_queue_depth = 2
home_mailbox = Maildir/
html_directory = no
in_flow_delay = 0
inet_interfaces = all
inet_protocols = ipv4
initial_destination_concurrency = 100
local_header_rewrite_clients =
mail_owner = postfix
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
master_service_disable =
milter_default_action = accept
milter_protocol = 6
mydestination = $myhostname, localhost.localdomain, localhost, $mydomain
mydomain = xyz.biz
myhostname = xyz.biz
mynetworks = 168.100.189.0/28, 127.0.0.0/8
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases
non_smtpd_milters = $smtpd_milters
qmgr_message_active_limit = 500
qmgr_message_recipient_limit = 500
qmgr_message_recipient_minimum = 1
queue_directory = /var/spool/postfix
queue_run_delay = 300s
readme_directory = /usr/share/doc/postfix.20.10.2/README_FILE
receive_override_options = no_header_body_checks
sample_directory = /usr/share/doc/postfix.2.10.2/examples
sendmail_path = /usr/sbin/sendmail
service_throttle_time = 1s
setgid_group = postdrop
smtp_always_send_ehlo = no
smtp_connect_timeout = 1s
smtp_connection_cache_time_limit = 30000s
smtp_connection_reuse_time_limit = 30000s
smtp_delivery_slot_cost = 2
smtp_destination_concurrency_limit = 10000
smtp_destination_rate_delay = 0s
smtp_destination_recipient_limit = 1
smtp_minimum_delivery_slots = 1
smtp_recipient_refill_delay = 1s
smtp_recipient_refill_limit = 1000
smtpd_client_connection_count_limit = 200
smtpd_client_connection_rate_limit = 0
smtpd_client_message_rate_limit = 100000
smtpd_client_new_tls_session_rate_limit = 0
smtpd_client_recipient_rate_limit = 0
smtpd_delay_open_until_valid_rcpt = no
smtpd_delay_reject = no
smtpd_discard_ehlo_keywords = silent-discard, dsn
smtpd_milters = inet:127.0.0.1:8891
smtpd_peername_lookup = no
unknown_local_recipient_reject_code = 550

what could be the issue?

share|improve this question
    
What's the output of host -t MX X.com ? –  Eric DANNIELOU Nov 13 '13 at 15:29
    
root@xyz [~]# host -t MX yahoo.com yahoo.com mail is handled by 1 mta5.am0.yahoodns.net. yahoo.com mail is handled by 1 mta6.am0.yahoodns.net. yahoo.com mail is handled by 1 mta7.am0.yahoodns.net. –  BoCode Nov 13 '13 at 15:36
add comment

4 Answers

in your server's /etc/hosts file, maybe you don't have your hostname on the 127.0.0.1 line?

share|improve this answer
    
Thanks for the reply. As a matter of fact i do have it. –  BoCode Nov 13 '13 at 15:28
add comment

I'd say you have some sort of firewall (iptables maybe) redirecting port 25 to your own mailserver, try excluding the mailserver's address from that rule..

share|improve this answer
    
firewall is disabled and i checked the iptables (there is no rerouting and any managing of port 25). Would a badly created PTR record be an issue? –  BoCode Nov 13 '13 at 16:11
    
How is your /etc/resolv.conf configured, does it use the same server that returns the correct MX lookups? BTW, it would help if you hadn't covered the domains that are not working, it's hard to externally verify the domains. –  NickW Nov 13 '13 at 17:00
    
Also, the firewall does not have to be on that machine.. in fact it's more likely on the edge of your network. –  NickW Nov 13 '13 at 17:01
add comment

I just couldn't send or receive mail, then could send but not receive and now got it working

Check if this answer can help you any (read my edit's in the question and my answer below) Postfix not sending/allowing receiving of messages after server (hardware) changed

share|improve this answer
add comment

Are X.com apart of mydestination = ? Also i belive that you need to set mydestination below myhostname, so we are sure that the variable is set, before we read it in mydestination

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.