Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am fairly new with Linux when it comes to mounting hard drives, so hopefully this is a simple question. I recently purchased a 3TB hard drive that would have read/write access with both Mac and Linux. The first step I took was to format the hard drive partition on a Mac system with "Windows NT Filesystem (Tuxera NTFS)".

Then I connected the hard drive to the Linux machine and ran the command:

sudo mount -o umask=0,uid=name,gid=name /dev/sdb2 /mnt/point/

So currently I have read/write access on both Linux and Mac. The slight problem I have now is that each directory that is created on the hard drive on the Linux machine has all the permissions enabled. For example when creating a new directory called "test" and then running "ls -lh" the output shows:

drwxrwxrwx 1 name name 0 Nov 13 13:18 test

and the directory "test" is highlighted in green on the terminal. I tried modifying the access permissions by executing:

sudo chmod -R 775 /mnt/point/

but this does not change anything, and the "test" directory is still highlighted. Would anybody happen to know if there are some restrictions with permission changes on NTFS hard drives? If so, is there possible way to solve this problem?

If worst comes to worst, and there is no solution. What is the best partition that would be able to have read/write access with Mac and Linux?

Thank you very much in advance.

share|improve this question

closed as off-topic by Zoredache, Grant, cole, Dave M, kce Nov 14 '13 at 17:23

  • This question does not appear to be about professional server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

You can't. ntfs has no knowledge of Linux permissions and ownerships. The only weapons at your disposal are mount options.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.