Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So I've got a home server running Windows Server 2003. I use a dual network card setup and Routing and Remote Access to link the internal, private network to the external connection. The external connection hooks directly to my cable modem (so no routers or other devices sitting between).

The problem I'm having is that I can't connect remotely from a location outside the house (so connecting to the server's external connection) to the server using either Remote Desktop or VNC. I have enabled both ports in Routing and Remote Access's firewall to allow access, and I have enabled Remote Desktop in Windows Server 2003.

The odd thing is that I can access my home server's SVN repository and I can even ping the server's IP. I am using the IP to attempt to connect, though I use a dyndns.com provided name to connect to my SVN repository, so it shouldn't make a difference (I know the IP is getting resolved correctly).

Any ideas on where to start diagnosing this one? I haven't seen anything in my server's event log. If any other info is needed, let me know. Thanks.

UPDATE: One last piece of information: We use a proxy server at work, which I'm nearly 100% sure is the culprit. I have a workaround--if I connect to our VPN (even though I'm already inside the building) I am able to connect to my home server. This is with VNC. However, is there a way to connect through a proxy using Remote Desktop?

ONE MORE UPDATE: Indeed, it was the http proxy I'm sitting behind at work that was causing the issue. An acceptable workaround is to use my VPN connection to bypass the proxy, and I'm in!

share|improve this question

2 Answers 2

up vote 5 down vote accepted

You mentioned that you cannot access your server "from a location outside the house". Does it mean that you cannot access your home server from any location, or just from work?

If you cannot establish an RDP session to your server from any location, and assuming that everything is properly configured, I'd suggest switching RDP default port (3389) to another one.

For example, try using port 33890 on your terminal server. I've seen this same problem a couple of times, and it happened because the customer's ISP was blocking traffic on port 3389. If the ISP blocks traffic by port number, then changing the default port to another one will let you solve this issue. However, if the ISP is filtering traffic at the application level (i.e., Layer 7), this tip will not help.

If the problem you're having only happens when you try to connect from work, that's probably because you're behind an HTTP proxy, which usually will only forward HTTP/HTTPS traffic, and then you won't be able to use other protocols (like RDP or VNC).

You can check that by using the telnet command, as pnti suggested. If telnetting fails, then it's quite likely that you won't be able to establish an RDP or VNC session from work to your home server.

share|improve this answer
    
I suspect it's the http proxy at work causing the problem. I'll try the telnet idea on Monday (working at home today). –  scottmarlowe Aug 21 '09 at 18:10
    
It was the proxy causing the problem. I found a workaround (connect to our VPN) which gets me around it. –  scottmarlowe Aug 24 '09 at 13:46

Try telnet to check access to given port from outside.

telnet home_machine 3389 for Remote Desktop or
telnet home_machine 590x (0 or higher) for VNC

BTW: Have you enabled remote access in Window Server (Computer > Properties > Remote) ?

If you use Vista you have to add telnet client.

share|improve this answer
    
Thanks for the suggestion. I'll give it a try. Oh, yes... remote desktop is enabled on the server. –  scottmarlowe Aug 21 '09 at 18:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.