Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Cent OS 6.4 in a corporate lab and the yum update fails with the below error:

I am able to access the same repositories through browser.

[root@LAB1 ~]# yum update
Loaded plugins: refresh-packagekit, security
base                                                     | 3.7 kB     00:00 [Errno 12] Timeout on (28, 'Operation too slow. Less than 1 bytes/sec transfered the last 30 seconds')
Trying other mirror.  
Error: failure: repodata/1e584feac3f3fb76ad4b6fb7e1bc8d44fa124814e9d186dc913ded3c63a216b3-primary.sqlite.bz2 from base: [Errno 256] No more mirrors to try.

Below is what I have in /etc/yum.repos.d/CentOS-Base.repo

name=CentOS-$releasever - Base

#released updates
name=CentOS-$releasever - Updates

here is what I have in /etc/resolv.conf

# Generated by NetworkManager

yum.conf file:


I am able to ping the above nameserver. And I have tried the yum update after running yum clean all but with same result.

I am able to wget/curl the same link and it connects and downloads. I also tried *yum update* right after which again failed with the same error. Here is the output:

[root@LAB1 ~]# wget
--2013-11-15 21:29:45--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4578998 (4.4M) [application/x-bzip2]
Saving to: “1e584feac3f3fb76ad4b6fb7e1bc8d44fa124814e9d186dc913ded3c63a216b3-primary.sqlite.bz2”

100%[======================================>] 4,578,998   5.52M/s   in 0.8s    

2013-11-15 21:30:50 (5.52 MB/s) - “1e584feac3f3fb76ad4b6fb7e1bc8d44fa124814e9d186dc913ded3c63a216b3-primary.sqlite.bz2” saved [4578998/4578998]

FINISHED --2013-11-15 21:30:50--
Downloaded: 1 files, 4.4M in 0.8s (5.52 MB/s)

[root@LAB1 ~]# curl -O  
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 4471k  100 4471k    0     0  67874      0  0:01:07  0:01:07 --:--:-- 1071k

Sometimes I am also getting the below error on some of the mirrors: [Errno 14] PYCURL ERROR 6 - "Couldn't resolve host ''"
Trying other mirror.

As I am new to Linux and networking, any help here is much appreciated.

share|improve this question
Run tcpdump and/or strace to see what's happening. – yoonix Nov 15 '13 at 18:26
@yoonix: I ran tcpdump and strace and it is giving a lot of good information, but as I am not familiar with networking/linux, I am not sure what to look for in the trace dump :(..Is there something i need to particularly looking for in the dumps? – Siva Nov 19 '13 at 15:25
up vote -1 down vote accepted

The issue got resolved by adding timeout=300 to the /etc/yum.conf. Thanks to all who tried to help.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.