Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have changed the apache2 (httpd) on CentOS 6.4 listen port to 80, 443, 25640 etc no ports seem to work

(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
                                                       [FAILED]

I can't seem to find out what is taking the port though

when I start httpd webmin shows http://puu.sh/5k8Dl.png and if I kill that httpd starts successfully however no hosted sites load and with

service httpd restart

I get the same port failed to bind. Could apache start in two different places when I start it as webmin shows it as /usr/sbin/httpd?

share|improve this question
    
Did this problem start after you added the additional ports? That might indicate a SELinux permission problem. The shell command getenforce will tell you if SELinux is enabled. –  Ulrich Schwarz Nov 16 '13 at 18:36
    
Ulrich Schwarz SELinux is disabled, the problem accrued after a user decided to install ALL apache modules from webmin... I removed all modules and reinstalled apache and php with yum reinstall httpd -y. –  Connor Gavitt Nov 16 '13 at 19:02
    
ulrich-schwarz forgot to mention I am using the root user. –  Connor Gavitt Nov 16 '13 at 19:25
add comment

1 Answer

if you have selinux disabled, are you sure the ports are not already used, use netstat to verify

share|improve this answer
    
Found the problem, some user on my system installed ALL the apache modules from webmin, they were taking port 80 as well. I fixed this with yum remove httpd then yum install httpd;yum install php –  Connor Gavitt Nov 17 '13 at 16:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.