Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My MySQL server is consuming a lot of memory.

Memory footprint 1. Memory consumption in descending order (top 4)

enter image description here

MySQL's memory consumption in particular -

enter image description here

Why is there so many number of mysqld processes? Are they processes / threads? They are consuming a lot of memory. Did I set that number somewhere?

Also my queries take a lot of time to execute and hence my website is getting slow.

A snippet of my my.cnf -

[mysqld]
key_buffer      = 16M
max_allowed_packet  = 16M
thread_stack        = 192K
thread_cache_size       = 8
myisam-recover         = BACKUP
query_cache_limit   = 1M
query_cache_size        = 16M

innodb_lock_wait_timeout = 120
innodb_buffer_pool_size = 500M

[mysqldump]
max_allowed_packet  = 16M

[mysql]
#no-auto-rehash # faster start of mysql but no tab completition

[isamchk]
key_buffer      = 16M
wait_timeout        = 60

I have run tuning-primer.sh to check what I am doing wrong. Related part of result of tuning-primer.sh -

MySQL Version 5.1.63-0ubuntu0.10.04.1 i486

Uptime = 176 days 0 hrs 24 min 31 sec
Avg. qps = 8
Total Questions = 128972512
Threads Connected = 6

SLOW QUERIES
The slow query log is NOT enabled.
Current long_query_time = 10.000000 sec.
You have 55628 out of 128972533 that take longer than 10.000000 sec. to complete
Your long_query_time seems to be fine

BINARY UPDATE LOG
The binary update log is NOT enabled.
You will not be able to do point in time recovery
See http://dev.mysql.com/doc/refman/5.1/en/point-in-time-recovery.html

WORKER THREADS
Current thread_cache_size = 8
Current threads_cached = 7
Current threads_per_sec = 0
Historic threads_per_sec = 0
Your thread_cache_size is fine

MAX CONNECTIONS
Current max_connections = 151
Current threads_connected = 5
Historic max_used_connections = 147
The number of used connections is 97% of the configured maximum.
You should raise max_connections

INNODB STATUS
Current InnoDB index space = 109 M
Current InnoDB data space = 10.32 G
Current InnoDB buffer pool free = 0 %
Current innodb_buffer_pool_size = 500 M
Depending on how much space your innodb indexes take up it may be safe
to increase this value to up to 2 / 3 of total system memory

MEMORY USAGE
Max Memory Ever Allocated : 929 M
Configured Max Per-thread Buffers : 405 M
Configured Max Global Buffers : 534 M
Configured Max Memory Limit : 939 M
Physical Memory : 3.94 G
Max memory limit seem to be within acceptable norms

KEY BUFFER
Current MyISAM index space = 1 M
Current key_buffer_size = 16 M
Key cache miss rate is 1 : 204
Key buffer free ratio = 88 %
Your key_buffer_size seems to be fine

QUERY CACHE
Query cache is enabled
Current query_cache_size = 16 M
Current query_cache_used = 8 M
Current query_cache_limit = 1 M
Current Query cache Memory fill ratio = 50.29 %
Current query_cache_min_res_unit = 4 K
MySQL won't cache query results that are larger than query_cache_limit in size

SORT OPERATIONS
Current sort_buffer_size = 2 M
Current read_rnd_buffer_size = 256 K
Sort buffer seems to be fine

JOINS
Current join_buffer_size = 132.00 K
You have had 10728 queries where a join could not use an index properly
You should enable "log-queries-not-using-indexes"
Then look for non indexed joins in the slow query log.
If you are unable to optimize your queries you may want to increase your
join_buffer_size to accommodate larger joins in one pass.

Note! This script will still suggest raising the join_buffer_size when
ANY joins not using indexes are found.

OPEN FILES LIMIT
Current open_files_limit = 1024 files
The open_files_limit should typically be set to at least 2x-3x
that of table_cache if you have heavy MyISAM usage.
Your open_files_limit value seems to be fine

TABLE CACHE
Current table_open_cache = 64 tables
Current table_definition_cache = 256 tables
You have a total of 130 tables
You have 64 open tables.
Current table_cache hit rate is 0%
, while 100% of your table cache is in use
You should probably increase your table_cache

TEMP TABLES
Current max_heap_table_size = 16 M
Current tmp_table_size = 16 M
Of 6404640 temp tables, 48% were created on disk
Perhaps you should increase your tmp_table_size and/or max_heap_table_size
to reduce the number of disk-based temporary tables
Note! BLOB and TEXT columns are not allow in memory tables.
If you are using these columns raising these values might not impact your 
ratio of on disk temp tables.

TABLE SCANS
Current read_buffer_size = 128 K
Current table scan ratio = 206 : 1
read_buffer_size seems to be fine

TABLE LOCKING
Current Lock Wait ratio = 1 : 84225
Your table locking seems to be fine

My Server specs -

Disk Size   80GB ( Used = 50GB )
RAM         4GB
Swap    4GB
Number of CPUs  8
OS type 32 bit
OS  Ubuntu 10.04
share|improve this question
    
Could you add your server specs to the question? –  sgtbeano Nov 18 '13 at 11:50
    
Done. added at the bottom of question –  Hussain Tamboli Nov 18 '13 at 12:04

1 Answer 1

up vote 1 down vote accepted

WHY SO MANY THREADS

I have seen this many times before. This is not a problem. It is just indicative of how the mysqld binary was installed. I have discussed this before : See my Mar 29, 2012 post : Identical mysql processes

Older source-compiled versions of mysqld will produce multiple threads. I don't know what setting can avert this. I usually like installed RPM versions rather than yum installing or doing the source compilation.

Optionally, you could just upgrade to the latest version. You could also look for the RPM version of MySQL 5.1.63 and install that. Otherwise, you need not worry about anything.

Since DB Connections are threads, you can change the number of connections by setting max_connections as high or low as needed. For example, you could set it on-the-fly with this:

SET GLOBAL max_connections = 500;

You will, of course, have to add that setting to /etc/my.cnf so max_connections stays 500 every time you restart mysqld.

YOUR ORIGINAL QUESTION

To find which queries take a long time, you can do this dynamically using pt-query-digest. Here are my DBA StackExchange posts on how to set it up:

Give it a Try !!!

share|improve this answer
    
Awesome answer! thanks –  Hussain Tamboli Nov 19 '13 at 5:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.