Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Problem:

Apache 2.4 on Ubuntu Linux 13.10 serves gibberish instead of content over https: using AuthBasic and .htpasswd-based authentication.

Here's an example:

‹Å»<:þãÕåød|~>¾…‹ÑõáéÙ§ã=œƒb*¢on¹˜Ë”xôµkl³J­"*g”ª=K­R:ÜCþ¸ž”ÛÓ”8O1sª\ýŠ£!†kØÿâõ”û+=a|@>òÙÂb>àä)N™°$Ùz ‹)1HNÖ­ˆ)¬în‘d£¯YZ3Ê™ŵˆ§¨×Z(;â]ËGKÚB- øœÙ¥ÕK5ï‘K>MU&cêÍH¼L>¡ÙnåÛ­Zr~âï êç¢YÎ9IÓÜÔ0àO¤SCí†GQ«‹¨ÅŸƒ>s(xŸ…L‘ˆ{”$z-¾àiD•¬¥éóçÐrÒ›ñˆ'ä<Œt@pèç´éDlºñT­mî«Y6ÕÓÃŒEÉÜ)›‚C ¾„Øàú,ŸºA¿E)õˆ×êwû}Ò´ÚAçÐ4[Ôëí Ez€Á)‘®™ÜÝz®°Â·‚,‡Jd´LåK–K$IÈN6e «ŒÊ¸³Â•ûÙ„.ÅÃ0ÒŒÝt¿W,Æ(ùmÕàÚró7ø ˜>˜„Pé„‚ó:"æ;Ú†X<Û¡¹8“ÌÛÒ¥zÏ¥_ø×Æ„E[¤vX¾±Ž*Å:§4-—ª/Ø‚nGðf _@Øf‰hâ?±Þ]'aû;ШRÝú’ õÎI¿ð-Ñ0 Ø<‘øÚ?ÃéòGË+ÖYgºk[3ªàó§üA¯w¹ÜìÕ/Ô.¸’hÆ!;ùnòÌ¿‰"¤Dͨ€ä|ªDðU¯­ÅÍè°š%ë9„Ûì

Instead of my ssl-enabled page served over https, which worked on apache 2.2.

A refresh fixes it, displaying the correct content.

Things I've done:

  • Updated all the Allow and Require tags in the site configuration files.
  • Enabled the mods I need (ssl, php5)
  • Reviewed the relevant documentation, which helped me migrate successfuly (until this issue).

Note:

  • Other (not-authenticated https, or plain http) work fine, serving correct content immediately.
  • Error log shows nothing out of the usual

Please let me know what other information I can provide to help diagnose the problem.

share|improve this question
3  
Looks like gzipped content. –  Michael Hampton Nov 18 '13 at 19:31
    
I had previously enabled compression of images and such. These rules were overwritten by the new apache install. Maybe they are still being compressed somehow? –  Josh Nov 18 '13 at 19:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.