Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Trying to promote a Windows 2012 server to DC in a 2008 domain and after passing all prerequisites and beginning the process, I get an error stating:

adprep was unable to bind to any domain controller

Here is the output from the debug log:

[2013/11/19:01:07:51.518] Adprep created the log file 'C:\Windows\debug\adprep\logs\20131119010751\ADPrep.log' [2013/11/19:01:07:51.518] Adprep successfully initialized global variables.

[Status/Consequence]

Adprep is continuing. [2013/11/19:01:07:51.542] Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is CN=Schema,CN=Configuration,DC=domain,DC=com. [2013/11/19:01:07:51.543] LDAP API ldap_search_s() finished, return code is 0x0 [2013/11/19:01:07:51.543] Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is CN=ZION,CN=Servers,CN=domain,CN=Sites,CN=Configuration,DC=domain,DC=com. [2013/11/19:01:07:51.544] LDAP API ldap_search_s() finished, return code is 0x0 [2013/11/19:01:07:51.544] Adprep was about to call the following LDAP API. ldap_search_s(). The base entry to start the search is CN=Schema,CN=Configuration,DC=domain,DC=com. [2013/11/19:01:07:51.545] LDAP API ldap_search_s() finished, return code is 0x0 [2013/11/19:01:08:10.901] Adprep was unable to bind to any Domain Controller (DC) over Remote Procedure Call (RPC) in the Active Directory Domain domain.com. [2013/11/19:01:08:10.901] Adprep encountered a Win32 error.

Error code: 0x6be Error message: The remote procedure call failed.

DSID Info: DSID: 0x18111880 winerror = 0x6be NT BUILD: 9600 NT BUILD: 16384

[2013/11/19:01:08:10.901] Adprep could not discover the Schema FSMO. The Schema FSMO must be discoverable for this operation to proceed.

[Status/Consequence]

The Active Directory Domain Services schema is not upgraded.

[User Action]

Check the log file ADPrep.log in the C:\Windows\debug\adprep\logs\20131119010751 directory for possible cause of failure. [2013/11/19:01:08:10.901] Adprep encountered a Win32 error.

Error code: 0x6be Error message: The remote procedure call failed.

DSID Info: DSID: 0x18111880 winerror = 0x6be NT BUILD: 9600 NT BUILD: 16384

[2013/11/19:01:08:10.901] Adprep was unable to check the specified user's group membership.

[Status/Consequence]

Adprep has stopped without making changes.

[User Action]

Verify the specified user is a member of Enterprise Admins group and Schema Admins group if /forestprep is specified, or is a member of Domain Admins group if /domainprep is specified, or is a member of Enterprise Admins group if /rodcprep is specified . [2013/11/19:01:08:10.901] Adprep encountered a Win32 error.

Error code: 0x6be Error message: The remote procedure call failed.

DSID Info: DSID: 0x18111880 winerror = 0x6be NT BUILD: 9600 NT BUILD: 16384

Any ideas where to look? I have verified connectivity to the DC and this server has no issues accessing network resources.

share|improve this question
    
Is the user under which you're running the prep a member of the Enterprise Admins group, the Domain Admins group and the Schema Admins group? –  joeqwerty Nov 18 '13 at 23:30
    
I'm running it using the default Administrator user, which is a member of all three groups you listed –  blizz Nov 18 '13 at 23:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.