Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have installed the 64-bit version of the Oracle ODBC driver (instantclient-odbc-windows.x64-12.1.0.1.0 from http://www.oracle.com/technetwork/topics/winx64soft-089540.html) on my 64 bit Windows 7 system. The driver shows up in the ODBC administration dialog. However, when I try to define an ODBC source I obtain the error message (translated from German):

The setup routines for the Oracle ODBC client in instantclient64_12_1 could not be loaded. System error code 126: The denoted module was not found. (C:\Program Files\Oracle\instantclient64_12_1\SQLORAS32.DLL).

After comfirming the dialog box a second message appears with basically the same message. A first check yields that the DLL does reside in the path given in the error message. Also the examination of the registry shows that both DLL paths to SQLORAS32.DLL and SQLORA32.DLL have been set correctly.

The installation manual requires the PATH variable to be set the same directory. This was also checked by me.

Is there any way to fix this?

share|improve this question

1 Answer 1

up vote 2 down vote accepted
+50

Download and install the Microsoft Visual C++ 2010 Redistributable Package:

http://www.microsoft.com/en-us/download/confirmation.aspx?id=14632

The problem is not with the SQLORA dlls, but the modules that those ddls refer to (missing from a default Windows installation).

share|improve this answer
    
Thanks a lot! I'll try this tomorrow morning (CET). –  Marcus Rickert Nov 25 '13 at 0:18
    
This fixed it! Thank you very much! I think it's a little embarassing for Oracle that they are not mentioning this prerequisite in an exposed position. –  Marcus Rickert Nov 25 '13 at 11:44
    
Thanks a million, solved it for me. And thanks so much too, Oracle. –  Andrew Schulman Feb 12 at 20:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.